Solved: Scaling an appended character or object

Hi all, noobish question here…
I completed the BSOD:Intro to Character Animation tutorial and decided to do more with the character. He is in one .blend file with his actions, etc. Then I created a dimly lit corridor, saved as another .blend file. I open the corridor.blend file and append the character from it’s .blend file. Since they were created seperately the scales of the objects differ, my character is 5 times the size of the corridor he is to walk thru.

How do I scale my character down in size? The character is on a seperate layer from the corridor, and if I scale him down in size, as soon as I move to frame 2, he’s lost the scale. If I set a scale key, he returns to his size by the next keyframe. So how do I scale the character, armature, and it’s actions down in size so it maintains it’s size throughout the animation?

I know it’s something simple that I’m missing…and sure, I could scale up the corridor and it would maintain it’s size since it has no keyframes…it’s a static object. Blender is so flexible that it should be able to scale the character down…how?


Scale the armature while it’s in Object mode.

The mesh should get scaled down automatically.

Tried that Mike…

And no luck…the character resized itself back to it’s normal size

I’m stuck…can anyone help?

I seem to get this behavior if i have the Record button ticked on my time line - so that no matter what translation I set, it switches back because of the key frames that exist.

Also, have you tried after scaling in Object mode to press ‘CTRL-A’ to Apply Scale to Object Data?

For this particular rig, you should be able to select the Master bone, and scale it, (in Pose mode) then keyframe that new scale, … do it on frame 1, and it should “hold”. … a keyframe is not actually necessary, though.

If the initial rigging had parented the mesh to the armature, then scaling the armature in Object mode would have worked.

Alternatively, for this rig, you can select the armature, mesh and eyes (make sure the armature is in Object mode), then scale them. Check that none of them have scale keys. (Select each object, with an IPO window open, there should be no keys/curves, if there are any, hover the mouse over the IPO window, press A to select all keys (toggle), then delete/x to delete the keys. (CTR-Z to undo if necessary).

As long as you don’t have any other scale keys set on that bone the scale should remain the same.

If you still can’t get it, post the blend file and I’ll take a look.


Mike_S, you hit the nail on the head, or close enough for me to figure it out. My mesh is parented to my armature, so I selected the armature in object mode and cleared all the scaling keys in the IPO window. Scaled my character down and set IPO keys for the new size. I also had to clear and reset the location IPO keys as well, since the character was scaled around it’s center. As I tried to figure this out, I did look in the IPO window, but didn’t figure it out.

Now I know and I hope this post helps other out as well.