SOLVED - Slight problem with UV Unwrap results

Hi everyone,

I will apologise in advance, because I think I’m missing something obvious here :slight_smile: I’ve tried searching, but I’m getting lots of results regarding unwrap - so also apologies if this has been covered before! :slight_smile: I’m trying to make a very simple prototype object in Blender, with a view to using it in a coding project I’m working on. I’ve followed a couple of tutorials on unwrapping, and consulted the Wiki manual - it’s almost producing the correct result, but since I’m only mapping a simple cube I have to assume that I’m the problem with the process :slight_smile:

I started with the default cube object. First of all, I made the gigantic mistake of scaling in object mode, then unwrapping. This gave me the expected collection of faces based on their original cube sizes, rather than scaled to a flat box a couple of units high. I was happy though, because I figured out my error without consulting the docs - after switching to edit and scaling the verts, I then had my expected 2 sqaure faces and 4 rectangular faces in my UV map.

What you’ll see from the image (and have probably seen a thousand times!), is that while the squares are perfect, the rectangular sides are skewed. At first I thought they’d been rotated, i.e. an easy (and expected) fix. But they’re actually leaning to one side. I immediately thought of fixing this by highlighting verts and simply moving them, but then I wondered if that was actually the correct thing to do. To perform the scaling, I used keyboard shortcuts and scaled to 0.1 with numeric entry. I then made every edge a seam (which is fine for my prototype), and unwrapped.

Any help or advice would be massively appreciated, and I am fully prepared for a bashing with the noob stick :slight_smile: The first image below shows the result immediately after applying seams, and using the standard Unwrap option. The second image shows the same operation with Smart Projection. Unwrap is definitely closer to what I want, except for the weird skewing on the sides. I only scaled the verts in edit mode - I didn’t transform or rotate anything.

Thanks guys!

F9> UV Calculation tab > set to Conformal (area) rather than Angle based.

After scaling in object mode - Ctrl A - apply scaling and rotation.

Fantastic, thank you so much Waternz :slight_smile: That did the trick - I thought I’d tried changing that setting, but that may have been when I didn’t have all faces selected. I kept making that mistake and took a while to figure it out, so was probably very close to having it working! Ah well, I appreciate the kick in the right direction - thanks again for replying :slight_smile: