[SOLVED] Tablet Pressure completely broken?

Hey guys I’ve been ripping my hair out trying to get any kind of pressure sensitivity working in blender. I’ve tested two different tablets (Intuos 4, Graphire) on two seperate computers (Both Windows 7 64bit), 4 different driver version installs and reinstalls AND 3 different Blender versions (2.68a,2.64,2.59) I’ve also tried both the win32 and win64 versions of Blender 2.68 and I cannot get tablet pressure to recognise in either sculpting or texture painting. Tablet pressure works perfectly fine in literally every other program on my PC, blender is the only program that doesnt seem to work. I beg you guys to help me T_T.

Did you enable pen pressure for radius or strength ?

Richard: Thanks for the reply. Yeah, I used to use Blender years back and pressure used to work with my Intuos 3(dead now). Clicking the pressure buttons on and off was the first thing I tried before installing/uninstalling drivers : (. Am I completely alone on this? I mean how can every other program on both PCs recognize two different tablets easily but blender can’t?

Ok guys I talked with a bunch of people in the #blendercoders IRC and apparently the issue is that the cursor number for the device was 7 and blender only recognized 0-5 so now it’s been fixed to handle a lot more and it should be in the Builder Blender build tomorrow morning for anyone having issues! Yay!

Indeed, I fixed the issue in r59799, so any build after that from http://builder.blender.org should give you happy tablet users.