[SOLVED] Visibility question

(Funnybob) #1

I’m trying to figure out some stuff that should be easy and obvious.

  1. When I click on the visibility icon of the top node in the outliner, it doesn’t turn off everything under it. Bug or feature? How can I do this? Select hierarchy doesn’t seem to work. Being able to turn off the top node for everything under it would allow me NOT to modify the visibility status of everything under it.

  2. If I click shift H in the viewport, it will isolate the selected objects. Alt H will turn the visibility ON on everything. What I’m looking for is to isolate an object, do what I need to do, then bring the visibility back to the way it was before, meaning not necessary all the objects. It needs to remember the previous visibility state before the isolation.

UPDATE: I was having a hard time doing this in the outliner in SCENE mode. Really easy in COLLECTION mode. So, I’m happy.

0 Likes

(Lumpengnom) #2

In 2.79 you would ctrl-click on the visibility icon or the render icon and it would turn all children on or off. In 2.80 this only appears to work with turning off visibility. Turning visiblity on again doesn´t seem to work and turning rendering on or off doesn´t seem to work either. Looks like a bug to me.

As for isolating an object this is called entering “local view” in Blener jargon. The default is the slash button on the numpad. This is annoyng imo opinion because I use it all the time and it forces me to take my hand of the mouse, so I changed it to alt-q which is 3ds Max default.

1 Like

(Funnybob) #3

I just tried in 2.79. Yeah, Ctrl click will turn everything off but it’s still not a good workflow as it overrides all the nodes under it. In the scene I’m working on now, I have hundreds of part in my set. Some of them have the visibility turned off on purpose. If I ctrl click OFF and back ON, then I lose the original state. I fail to understand why turning the visibility OFF the top node doesn’t just turn OFF everything else under it without affecting the original state of the nodes under the top one.

0 Likes

(Funnybob) #4

I will make a bug report concerning 2.80

0 Likes

(Lumpengnom) #5

Well, turning off the visibility via the eye symbol is for turning it on and off permanently. If you want to return to the original state you use “local view”.
You can select hierarchies either by ctrl-click on the objects symbol in the outliner, for example if the object is a mesh object you would ctrl-click on the triangle thingy left of the text. After that you would hit slash on the numpad for isolating.

Or you can select the object whose hierarchy you want in the viewport and then hit shift-g and select by certain traits (children, immediate children, siblings …)
Note that if you select by children with shift-g you lose the selection of the parent which I find a bit silly but, well, that´s how it is.

0 Likes

(zeauro) #6

So, why are you not satisfied by simple click on collection item ?
When the eye of collection is closed, visibility of objects is not represented by closed eyes but the disabling of display of objects is represented by greyed out names.

0 Likes

(colkai) #7
    • The Collection eye icon controls visibility for that collection, based on which icons within the collection are visible. This way, you can have only certain items in the collection visible, then hide them en masse.
      However, what is currently missing from 2.80 is the ability to affect the visibility of all items in that collection via a single click. I very much miss that feature and hope it gets re-implemented soon.
      To hide a collection not just from view, but from render, you can use the collection settings and mark is as “exclude”, then it doesn’t show up in the render at all. This is very handy where an object is build up from multiple items in a collection. Exclude that collection, then create instances of it for the actual render.
    • Shift+h and Alt+H are working as they should. To isolate an object, I use “local view”, numpad ‘/’ works for that in 2.80 as it does in 2.79
0 Likes

(Funnybob) #8

Local view is not necessarily what I need. My set could be made of a top node, with hundred or parts in subgroups. All I want is to turn off parts of my set by clicking it’s top node visibility icon.

0 Likes

(colkai) #9

Local mode works on all selected objects, so you can select a few, hit local mode and work on them.
In 2.8, you can even edit multiple objects. I’m not 100% what the issue is. Again, especially as you can have sub-collections etc, so by turning off visiblity for that sub-group, you hide everything in it.
I operate on a ‘work’ collection, just so I can isolate that at will for that very reason.

0 Likes

(Funnybob) #10

Oh! I was in scene mode instead if collection! I can do what I want with collections. Solved! Thanks

0 Likes

(colkai) #11

Glad you got it sorted. :slight_smile:

0 Likes