[SOLVED] What would cause the New Object Panel to be disabled?

I have never come across this until 2.69 and can’t figure out what I would have done to cause it. It’s happened to me twice now on 2 different computers - once in 32 bit and now again in a 64 bit build from Graphical. After doing some dynamic sculpting, if I try to add a new object to the scene, the panel for changing the initial settings is completely disabled. Even after opening a new scene or restarting Blender, this panel is disabled.

Going to try other things before calling it a bug, but was wondering if someone knew of some key combo or setting that would cause this? I can’t find any reason for it.

Win7 Home Prem. x64
AMD FX8120
16gb ddr3
Blender 2.69.1 R60893

Just tried in r61126 on Mac OS and it works as expected, I don’t know.


Works fine here - win8, 64 bit. I did some sculpt in Dyntopo, then switched to Object mode and then added a new sphere - no problem here.

Are these with installers or the zip files?

I can’t duplicate your symptoms either (2.69 x64 official on win7).

I had strange issues with greyed-out panels in a previous release because of startup.blend and/or userprefs carried over from previous releases. I didn’t troubleshoot further but starting fresh fixed the (similar) issue I had.



Thanks for looking folks. I fell asleep downloading, so will have to wait until tonight to try official build, but I think something is corrupting or changing some option in the startup blend, just haven’t figured out what yet. If I choose File>Load Factory Settings it works again, but restarting blender, or a new file using my custom setup it’s disabled again. I don’t think it’s because I carried them from past installs as it worked at least once in order to start the project I’m currently doing.

Well if anyone is interested, the only thing I have been able to determine is that the startup blend somehow is involved. If I load factory settings, create a new one, or replace with an old one - it seems to work normally again. I can’t seem to replicate the problem on purpose either, but still find it strange that it’s happened twice now.

Thanks again all for looking into it.

The culprit could be an add-on? One which you have activated in your own preferences but not in the default, and which conflicts with latest releases?

Just a thought.


I would be inclined to investigate this some more.

I will keep investigating, but I have a bunch of things going on right now and don’t know how long that would take. Will post back if this thread is still open.

There are some things about it being an add on that don’t quite make sense to me, but I guess anything is possible. I’ll check later but I don’t think any I have turned on that are flagged as broken.

  1. I haven’t changed my installed addons since 2.67
  2. I hadn’t turned any on even for single use
  3. I didn’t use any addons in the file that the problem occured. Just blocked out a mesh from a cube and started sculpting.
  4. I had been working in that file for a few days before it happened.

Would it make any sense to try and do a file comparison between two startup blends? Is that even possible without special tools? I don’t know anything about their structure, so I’m just throwing ideas out thinking it may point to something that got changed?

Even after opening a new scene or restarting Blender, this panel is disabled.

This puzzles me, given you didn’t save your startup file before closing, but I don’t think so.


Well I was wrong, looks like it’s userpref.blend that’s causing it. Completely forgot that I had duplicated it as well. However same situation, disabled all addons - no effect, changed each setting one at a time (pretty sure I tried them all) - no effect, replace with a different file - works.

Hi Storrboy. Sometimes there is info in the console. View menu toggle console see if it says anything about a conflict or a bad operator or maybe rebel alliance sneaking onto your death star. Similarly with the info window usually highlighted in red. But you have to drag it open from the default collapsed position.

I had done that thanks, and the console didn’t report any errors, just the actions taken.
It seems Larry Phillips found a bug tracker entry that solves it http://www.blenderartists.org/forum/showthread.php?317443-PROBLEM-Toolbar&p=2513625&viewfull=1#post2513625

I have tested this and it does solve the problem - I had been playing with undo settings to reduce memory usage - but what threw me off that track was that even after I tried turning it back on and testing, it didn’t work. I see now it only kicks in after restarting Blender or a new file.

I’m going to suggest adding this caveat to the wiki. To me the consequences of turning it off are not clear in the current description of it.

Thanks again all for helping.