Solving the armature's collision problem

I solved that problem of “flying armatures”, without using other meshes.
All you have to do is a ghost mesh! The problem was the armature colliding with the mesh! So, to solve this, avoid the collision! The mesh has to be a ghost!
Then you can use the Armature’s collision’s radius.

You can also turn off the collision faces of the mesh. I do that. I don’t know why exactly, because it’s a little more work, not much though with copy draw mode.