Some confusion with the quickstart part of the manual


I am not entirely new to blender, but still oblivious of half its functionality. Yesterday i was going through the gingerbread-man part of the manual i found online and i had some problems. Part of these might be because the manual has not been updated for the latest UI changes in blender.

Firstly: Making a camera or a light track an object. I select the camera, then shift-select the object, and press ctrl-t. I get a pop up menu, both choices mean nothing to me so i selected one at random (and later tried the other one with just as little success). The camera is tracking the object somehow, but in a wrong way. It absolutely refuses to look at the object, when i move it it keeps looking the other way (rude). I did try clearing the rotation (alt-r), no effect at all. When i tried to clear the tracking (alt-t) it still kept behaving the same way (looking away from object). What goes wrong here?

Secondly: When adding the armatures it seems i am expected to add new armatures while in edit-mode for the armature object. But when i am in edit mode for an armature the ‘add’ menu only has a ‘nothing’ item, so i can not add any more armatures. I was not allowed to duplicate them in edit mode either. Is this a new system where each ‘chain’ of armatures has to be a separate object?

Thanks for reading.


thanx for feedback. As you might have read in the News & Chat forum docs are updated off-line for the moment, but they will be back online soon.

Regarding your points:

1 - You probably used the random option ‘Constraint’ whereas
‘Old track’ is the old way, which should work with ALT-R. ‘Constraint’
Actually set a constrain to the camera, which must be edited in
the ‘Contraint’ panel and does not care of ALT-R (it is also insensible to ALT-T). The off-line doc should be already ok, but your
feedback is precious and I’ll check.

2 - THis is a bug, and is already fixed on the CVS waiting for the release of
the binary you can add a second armature in Object Mode and Join the two later o. Duplication in Edit Mode works, anyway, have you selected the bone(s9 to be duplicated correctly (it/they should be full yellow)


Thanks for the reply. I guess that after adding a contraint (which would not go away) doing another ctrl-t and selecting old track did not remove the contraint. What kind of a name is ‘old track’ anyway? Who wants their camera to ‘old track’ an object? Bleh.

I’ll play around with the armatures some more. I saw other people having the same problem in the thread about new features/bugs. I do not really need armatures for my current project anyway so it’s no biggie.