Some games insta-kill my X server (Fedora 6).

First one I came across was XMoto, which I came across by looking through packages in YumX. The more recent game, and the one I care about more, is Savage (I want to try it, since I’ve gone to the trouble of downloading it for free).

What happens is I try to start the game, the screen goes black, switches to one of the command line login screens, and then the X server starts up again and I get the graphical login screen.

I’ve tried running it in gnome (what I usually use), KDE, and Blackbox.

I get no error messages displayed (maybe there’s somethign in a log file, I don’t know). I’ve tried doing some web searches with Google, but I got little for it. I also tried looking at the officil site and search the official forums, but found no solution (which should be pretty obvious).

Uhhh… I expect it’s pretty obvious what I want from you (soul, earthly possesions, arm, leg ;)), please give it to me if you can.

EDIT: Looks like it’s even more games, I tried Suabraten to as a checking sort of thing, and it suffered the same thing.


I got rid of Fedora core a long time ago… (Fedora Core3 I think)

it is not really verry good for the novice-intermediate desktop user…
recently i tryed the Fedora core 6, and got bunked on the hardware 3d install.

If you want a nice game system, try KANOTIX linux… it installs from CD, and to get your kernel optimized and your drivers installed you only need to do a couple scripts…

goto root by typeing sux…+password
init3 (this is the stable drivers)
or -c (this is if you want compiz,and beryl,and bleeding edge beta drivers, [you know you want em!!] )

after a few seconds it will pop you back into KDM the kde login window.
reboot, and install your games!!!
apt-get update
apt-get install blender
apt-get install yafray
and you will be ready for work too :wink:

Edit: you might want to do a apt-get dist-upgrade very first to make sure everything is bleeding edge for you :slight_smile:

Type the games name in the Terminal/Konsole - to run the game - and copy and paste the info given out here. Also give us the info in the log file.

my suggestion is, that you post this to fedora community forums. more fedora users there, I’m sure.


I’ve discovered that the problem lies the NVIDIA driver version, there’s a known bug. I tried getting a different RPM one working, but didn’t succeed. Might try again some other day.

I did get Savage working though, by changing a seting in */Savage/game/startup.cfg . I got told to change the “setsave vid_mode” value to 1, which worked.

Now I just need to figure out how to get it working with alsa…

that is a great tip on the startup.cfg

Are you getting no-sound or garbled sound?

I found 2 utilitys that have helped me with games and music at the same time…
make sure both master and the PCM volume are turned up, also check the ratio buttons to make sure that pcm is not muted… (This is usualy the case. for some reason they think everyone needs muted sound by default. and like so many other drivers and applications in linux you need to manualy go in there and tweak every aspect, to make it function like comercial [working by default] software. Which brings me to a funny quote “Linux is only free if your time is of no value to you.”)

I have a soundblaster audigy 2… the program “aumix” allows me to listed to streaming radio, and play games at the same time using alsa. the mixer will give you sliders for Master and PCM, most games will follow the master slider, while XMMS,XINE,and VLC can be tweaked to only use PCM, or go over to one of the “line in” channels. it is nice to be able to tweak the volume of games and music independantly :slight_smile:

On another note… If you are out of awnsers, and need further help, try the fedora core IRC channel…
But dont log in with a male name… Sign in with a female name, and play a little bit dumb… you will have geeks Private messaging you left and right. Flirting a little bit helps, also let them know that you are single and that you really like technology.
With a guys name I only got the usual snob response : “OMG RTFM!” or some other stupid remakrs about me not being the “Uber geek”. I hate cliques :frowning:

Even with all the free “pen!x driven” help, I decided to move to Debian. everything “Just works for me”… I did not need the IRC channel, or the help forums… everyhting just set up and works correctly.

Kanotix is about to release a new live CD, and Ruhmour has it that you will not have to go to the command line for the Kernel or the graphics drivers!

With PCLinux and other mandrake based distros I had to get rid of alsa, and use OSS… this also might help you in Fedora., i highly recommend trying to troubleshoot/reinstall Alsa first… the OSS drivers give me funky squeelch sounds when the CPU is under a heavy load.

Well, thaks again for the tip, hope you get everything working for you :slight_smile:

My sound problem is just the usual sort of thing, something like the game using OSS by default. And OSS doesn’t let you have more than one thing try to use the sound card at once. I think it’s possible to set up like a wrapper or something around the OSS stuff so it uses alsa instead of hogging the hardware.

I do have sound setting control stuff, there the thing which comes with gnome (and I have also come across alsamixer elsewhere, while finding out about recording things from vinyl).

I found help enough as onesam in #savage and #fedora-games. But I’ll remember that, even if I don’t actually use such tactics. “How to get help on the intermet: preted to be a girl.” :smiley: