Some Linux newbie questions


(Bagration) #1

I’m thinking about installing Linux on my computer, but after Googling I’m still left with questions and I was hoping the many Linux-guru’s on this forum could answer some of them. :slight_smile:

  1. If I save a file under one OS, could I work with it under the other OS? I read it isn’t possible to write to an NTFS partition in Linux, is that really true? And if so, how do you people solve that?

  2. Say I want to download Blender and install Ubuntu, do I have to download the complete source and compile it? Doesn’t that take very long?

  3. In a dual-boot system, do you need to have all of your software double? 2x GIMP, 2x Blender etc.?

Thanks in advance, even if you can only answer one of them.


(Bussman) #2

I’m no Guru but here it goes in a nutshell:

  1. Make a partition shared by both OS (I’m assuming a dual boot system here, since you mentioned it). More info. Otherwise, network the two machines and learn about samba.

  2. There are Blender Linux binaries.

  3. Yes. Unless you want to use wine but I don’t know what the performance would be like for Blender or Gimp.


(knellotron) #3

Linux can read NTFS without problems. The support for writing to is “experimental,” although it’s “beta” on some distros now. That means that it’s better than it used to be, but still not perfect. Last year or so, a bad job at writing to an NTFS disk could make the disk unbootable, but I think those days are gone.

Also, there are ext2 & ext3 drivers available for Windows, so you can access your Linux half from Windows with no fuss.

  1. Say I want to download Blender and install Ubuntu, do I have to download the complete source and compile it? Doesn’t that take very long?

No, the only main distro that’s completely source-based is Gentoo. Ubuntu installs pre-compiles stuff off the CD. That means that the bulk of the time spent during the installation is copying all the data from the CD to your hard drive, then downloading the patches to update itself. You don’t even have the option for compiling until the installation is complete.

For the end-user like you, compiling is basically an alternative method for installing programs. There are advantages and disadvantages, but that’s a long topic.

  1. In a dual-boot system, do you need to have all of your software double? 2x GIMP, 2x Blender etc.?

Yes. Although after a while, you’ll definitely be using one OS more than the other, so you can erase one just to reduce the redundancy.

I have run the Windows version of Blender in Linux under Wine, as mentioned, and the performance was surpringly identical. This is mostly because Blender is written using friendly APIs; other programs aren’t so nice. Generally speaking, stuff that runs on Windows 98 will run on Wine.

As for Gimp, I wouldn’t try it. It was designed for Linux’s usage of multiple desktops and window behavior, and so the Windows port is a bit awkward. It shines on native Linux.


(yfkar.) #4
  1. If I save a file under one OS, could I work with it under the other OS? I read it isn’t possible to write to an NTFS partition in Linux, is that really true? And if so, how do you people solve that?

I’d suggest creating a FAT partition to share files between Linux and Windows, as they both can write on FAT. Windows can’t read Linux’s partitions (at least without special drivers) but Linux can read Windows’.

  1. Say I want to download Blender and install Ubuntu, do I have to download the complete source and compile it? Doesn’t that take very long?

If you want to install Blender in Ubuntu, the easiest way is to write “sudo apt-get install blender” in a console and it downloads and installs Blender automatically, or you can use a package manager to do it.

  1. In a dual-boot system, do you need to have all of your software double? 2x GIMP, 2x Blender etc.?

Practically, yes.

I’m on a dual-boot system myself. Learning all the quirks can be quite tedious sometimes but it’s also rewarding. :slight_smile:


(knellotron) #5

Last time I checked, the repository only has v2.36.


(Duoas) #6

I dual boot also. I’ve never needed (or wanted) the ability to write to the other OS’s dataspace. It’s easy enough just to read the data. (Use the mount command in linux to get to the FAT32 or NTFS stuff, and use either the ext2 or ext3 windows driver or a friendly utility like explore2fs to get at the Linux stuff.) I don’t like reiser. Stick with ext3.


(hydravien) #7

ok i have a question thats been nagging at me for awhile. i recently setup a dual boot because i had a spare partiton i wasnt using(well it had some recovery files on it but too late now…)
so i have my fedora linux and windows xp. if i boot to xp i am unable to see the linux partition and in linux i cant see the windows partition. windows is in ntfs and im not sure what linux is. the big prob is i can see any of my mp3 files or .blends because they are no windows and i want to work in lunix. i am baffled as to why its like this for me


(knellotron) #8

Well for Windows, here’s two drivers that you’ll need to read ext2 & 3:
http://www.fs-driver.org/index.html
http://ext2fsd.sourceforge.net/

For Linux, Iuld be able to mount it by typing “sudo mkdir /mnt/windows” then "mount -t auto /dev/hda1 /mnt/windows " That should at least let you read it. I don’t know what the default driver for NTFS is on your distro. You might need this:
http://www.jankratochvil.net/project/captive/


(Duoas) #9

That’s entirely reasonable. No OS is under any obligation to dink around with another OS’s dataspace.

That said, it’s easy enough to overcome.

Linux

First, make sure your system has an NTFS driver installed. If it doesn’t, google the latest and install it. I use Red Hat, so I got an RPM and installed it that way.

Open a command console (gnome-terminal, konsole, dtterm, xterm, or whatever).

[>] mount directories

For each Windows drive you wish to read, you need to make a directory to serve as proxy. So, assuming you want to connect to your windows C: drive, you’ll need a directory. Type
md /mnt/c
This creates a directory in the standard place. I’ve named all my drives, and I prefer to access them directly off the root, so I typed:
md /ceres
md /duoas
md /euros
for my C:, D:, and E: drives.

[>] backup /etc/fstab

Type the following exactly:
cd
cp /etc/fstab .
This saves a copy of the system file you will be modifying in your home directory. So if you mess up your system you can safe boot and restore the file to make your system work again.

The fstab file tells linux how to access the various drives in your system. We’re going to add your windows C: drive so you can access it from linux.

[>] editing /etc/fstab

Type su to change to the root user (you’ll have to supply the root password). Everything you type from here on out must be absolutely correct or you’ll mess-up your system.

(When you’re done with everything below, type exit to leave super-user mode.)

If your favorite text editor were vi, type
vi /etc/fstab
Substitute emacs or gedit or kedit or whatever you prefer for vi. (If you do start vi and want to escape, type :q! and press the enter key.)

[>] mount points

First an example. Do not simply copy this. Your system will differ. My fstab file looks like this:

LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/hda7               swap                    swap    defaults        0 0
/dev/cdrom              /mnt/cdrom              udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0
/dev/hda1               /ceres                  ntfs    ro,noauto,user,umask=0222  0 0
/dev/hda5               /duoas                  vfat    ro,noauto,user  0 0
/dev/hda6               /euros                  vfat    rw,noauto,user  0 0

Most of this file was created by the system installation. The only things I added are the last three lines for my Windows drives (ceres, duoas, and euros). The line you are interested in is the one for ceres.

The first item is /dev/hda1. This is the location of the device driver to read my C: drive. It is probably the same on your system. (If it’s not, it won’t work when you’re done, so you’ll have to look it up and fix it.)

The second item is the full name of the directory you created above.

The third item is the type of file system in use: ntfs or vfat (FAT32).

The last item is a list of options that control how you will be allowed to access the drive. This is very important.
ro = read only
noauto = don’t automount (you can omit this one. See below for why.)
user = means you can use it without needing to have root user access.
umask=0222 = security mask. Means that files on the drive cannot ever be modified.
0 0 = er, I don’t remember, but they’re necessary.

So your line will likely be:

/dev/hda1    /mnt/c   ntfs   ro,user,umask=0222 0 0

Save the file, exit the editor, and type ‘exit’ to leave super-user mode.

Restart the computer.

[>] accessing the drive

Now you can go to the command prompt and type
cd /mnt/c
to see your C: drive in all its glory.

If you specified noauto you’ll first have to mount the drive. Type
mount /mnt/c
to mount, and when your done type
umount /mnt/c
to unmount.

If you placed your new proxy directory in the /mnt directory, both Gnome and KDE are smart enough to put an icon on your X desktop to allow you to browse there. If not, you can create one easily enough.

Windows

Google an ext3 driver. (Hmm, see last post.)

Hope this helps.


(hydravien) #10

thx for the reply ill try tomorrow after i get off school


(Apollux) #11

Or change to SuSe, it mounts all your partitions automatically whenever you try to read them… no more messing with /etc/fstab or with mount commands

Just plug and play, even for internal hard disks.


(Bagration) #12

Thanks for your help. I am going to try Ubuntu now. Wish me luck! :wink:


(knellotron) #13

That’s a Konqueror / Nautilus thing, not a Suse thing.


(yfkar.) #14

Breezy has 2.37a. And you probably can also get 2.40 when it’s released from the backports.


(Bagration) #15

Ok, I’m typing this in Ubuntu and here come the next questions :):

  1. I got Internet working, but when I rebooted and logged in, the system would hang on a brown screen for 5-10 minutes. I can move the mouse cursor though. After those minutes the desktop will appear as usual. When I deactivate the wireless network connection the problem is gone. I have a Broadcom wireless network card and did something like this to get Internet working:

sudo apt-get install ndiswrapper-utils
sudo ndiswrapper -m
sudo ndiswrapper -i /pad/naar/.inf-bestand
sudo ndiswraper -l
echo sudo ndiswrapper | sudo tee -a /etc/modules
sudo depmod -a
modprobe ndiswrapper

  1. Would anyone happen to know of a simple program to manage partitions? I’d like to resize and delete some of them.

  2. Did anyone have any problems with the Wacom Volito (not every point on the tablet corresponds with a point on the screen, changing pressure sensitivity…) and were you able to solve them with these instructions?
    http://linuxwacom.sourceforge.net/index.php/howto/mouse1
    Or with these? (compiling a kernel :o)
    https://wiki.ubuntu.com//WacomTabletIssue


(phlip) #16

Google doesn’t give any details on /etc/modules - do you want /etc/modules.conf?
If so, you don’t want to write “sudo” to it - its directives aren’t commands, and even if they are it’s run as root so you don’t need sudo. I think you want something like

echo install ndiswrapper | sudo tee -a /etc/modules.conf

though I’m not sure (and I don’t reccommend messing with this unless you are sure…) I’ve never used ndiswrapper so I can’t comment on the rest of that.

fdisk will do whatever you need, but you might be able to find a more user-friendly GUI…


(Apollux) #17

“Parted” has a nice GUI.


(hydravien) #18

ok its awhile after the fact but i got into my c:/ drive after a combination of your posts and google. thanks i can listen to my mp3s in linux now


(Bagration) #19

Ok, this time I’m really stuck. As Apollux recommended I tried GParted for partitioning. There was a drive called “Acerdata” visible in Windows Explorer before. It was empty and created by the manufacturer. GParted told me it was a Fat32 partition. I resized a few partitions, deleted Acerdata and created a new, larger Fat32 partition (to be used as document storage between Linux and Windows). But now it isn’t visible in Windows Explorer! It only lists my Acer partition with Windows on it. I assumed Windows would automatically detect supported partitions. The Disk Manager (right click My Computer, Manage) does list the partition (healthy), but with no name and I can’t open, format or assign a drive letter to it (only deleting is allowed, the rest is grayed out).
Any hint would be much appreciated!

@phlip: I’m sorry, that quote wasn’t exactly what I typed. The point is: I got my wireless internet-connection working through ndiswrapper, but now that same connection causes the system to hang after I log-in. Everytime before I reboot from Linux, I have to deactivate the wireless connection (System -> Administration -> Networking) and after I log in again I need to reactivate it.


(Apollux) #20

Open fdisk (the Linux one, not the Windows one), select your hard disk (usually is /dev/hda) issue a partition table printout (the command “P” if I recall correctly) and give us that printout. I’m guessing that Gparted assigned a wrong file type ID to the disk and that is causing Windows to stop reading it, as a well though safety measure.