Some Linux newbie questions

This is it:

Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1         383     3076416   12  Compaq diagnostics
/dev/hda2   *         384        1913    12289725    c  W95 FAT32 (LBA)
/dev/hda3            1914        7477    44692830   83  Linux
/dev/hda4            7478        9729    18089190   83  Linux

hda1 = junk from Acer
hda2 = Windows XP partition (Fat32)
hda3 = data partition that Windows doesn’t recognize (Fat32)
hda4 = Ubuntu partition

Yup, there is your problem !!

Change the partition type ID for /dev/hda3, from “83” to “c”, that should fix your problem. Fdisk allows you to do that.

:wink:

Thank you so much Apollux! I’ll sacrifice three sheep to honour you. :smiley: Shouldn’t GParted have done this automatically?

While Explorer does list my data partition, it also lists my Linux partition with a question mark. But that doesn’t really matter. Thanks again!

LOL… glad to be of any service. Parted should had made that change as it usually does… but maybe the user forgot to specify the file system type on the GUI ? :wink:

BTW, you are the first one to get the true meaing of the Nickname :smiley:

@ Bagration

As Ubuntu is debian-based I can recommend this doc for you, which helped me to get my Intuos3 to work properly.

Important: Have the most recent kernel installed provided by your distro, because you need up to date evdev and mousedev drivers !!

Troubleshooting:



http://linuxwacom.sourceforge.net/index.php/howto/viewdata --> try also /dev/input/event1 and event2

if that´s ok all then:


where you can test if wacomdrv is REALLY controlling your tablet.

For your networking problem:
how do you connect to the internet?
what chipset has your wireless card, is it built in or pcmcia?

I’m back with another problem. Sorry about not replying for so long; I was too busy screwing up my laptop. :expressionless:
I wanted to make my Ubuntu partition smaller, but the data was on the beginning of the partition. I tried moving it with FDisk; Move beginning of data in a partition, but that just destroyed Ubuntu. With a Live CD I removed the damaged partition and reinstalled a fresh version. My table now looks like this:

Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1         383     3076416   12  Compaq diagnostics
/dev/hda2   *         384        1913    12289725    c  W95 FAT32 (LBA)
/dev/hda3            1914        8142    50034442+   c  W95 FAT32 (LBA)
/dev/hda4            8143        9729    12747577+   5  Extended
/dev/hda5            8143        8270     1028097   82  Linux swap / Solaris
/dev/hda6            8271        9729    11719386   83  Linux

Unfortunately Grub can’t boot Windows anymore (on /dev/hda2). It does list it as an option in the boot menu, but when I click it, I get a Grub prompt. When I type in root (hd0,1), chainloader +1, makeactive, boot, it says something like “Grub loading stage2” and then goes back to an empty Grub prompt.
This is my menu.lst and I can’t find a grub.conf.

# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.           
default		0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout		10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'

# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title		Windows 95/98/NT/2000
# root		(hd0,0)
# makeactive
# chainloader	+1
#
# title		Linux
# root		(hd0,1)
# kernel	/vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specifiv kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
# kopt=root=/dev/hda6 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,5)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## nonaltoption boot targets option
## This option controls options to pass to only the
## primary kernel menu item.
## You can have ONLY one nonaltoptions line
# nonaltoptions=quiet splash

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## ## End Default Options ##

title		Ubuntu, kernel 2.6.12-9-386 
root		(hd0,5)
kernel		/boot/vmlinuz-2.6.12-9-386 root=/dev/hda6 ro quiet splash
initrd		/boot/initrd.img-2.6.12-9-386
savedefault
boot

title		Ubuntu, kernel 2.6.12-9-386 (recovery mode)
root		(hd0,5)
kernel		/boot/vmlinuz-2.6.12-9-386 root=/dev/hda6 ro single
initrd		/boot/initrd.img-2.6.12-9-386
boot

title		Ubuntu, memtest86+
root		(hd0,5)
kernel		/boot/memtest86+.bin  
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title		Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda2
title		Microsoft Windows XP Home Edition
root		(hd0,1)
savedefault
makeactive
chainloader	+1

I hope my Windows partition isn’t damaged. I didn’t do anything special with it and all of the files are still visible by mounting it.

I really did change it to Fat32 in GParted, when I made a swap partition recently I had to give it the right id again in Fdisk.

@krizu: Thanks for the Wacom links. I’ll try them soon.

For people with similar problems with WiFi:
I have a Broadcom 802.11g network adapter (that’s about everything I know about it) and a Sitecom WL-114 router. I think internet works ok now after I followed these procedures:
http://www.ubuntuforums.org/showthread.php?t=25683
But also ndiswrap bcmwl5a.inf .

Again, thank you very much for the help. You are the only reason why I dare to try Linux.

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda2
title      Microsoft Windows XP Home Edition
root      (hd0,1)
savedefault
makeactive
chainloader   +1

Change the second line to read

rootnoverify (hd0,1)

Did you move your Windows partition? The Windows bootloader is notoriously stupid. It could be failing because it is on hda2 and not hda1, but I’m no expert here. (If you didn’t move anything, then ignore this.)

Hope this helps.

Thanks for replying.
I tried rootnoverify, but without success. I also removed savedefault.
I believe Grub starts counting from 0, so (hd0,1) means hda2. Windows must be on it; I can mount it and see all of the folders, like Program Files and Windows, sitting there.

I am not to firm with grub as I am still using lilo for my dual-boot system.

Here’s one thing to tryout:

  1. found this on a ubuntu mailing list: go to your bios settings and change the settings for your hd from auto to LBA seems to be a similar problem as described in #3

  2. Next try: when at the grub bootprompt open grubconsole ( i forgot the key but google is your friend) and try to manually boot your winxp with:


grub>rootnoverify (hd0,0) (–>in case the xp MBR is in the small partition in the beginning of /dev/hda)
grub>chainloader +1
grub>boot


try (hd0,1) as well…

  1. if that doesn´t work, maybe your partition table became somewhat, err corrupted - read this:
    http://lwn.net/Articles/86835/

  2. here is another, not too fine approach to restore the winxp MBR at least, afterwards you can use your ubuntu installation-cd to reinstall grub or switch to lilo (which is working fine for me with WinNT/Xp now for 8 years)

http://www.linuxgazette.com/node/9944

although these are for RedHat et al it’s still linux…

sorry for not having THE plan for your problem.

krizu

You know, you could just stick your Windows CD back in and tell it to restore the system. This would wipe grub off the MBR, but you can use the linux CD (or your backup diskette) to get back into linux, then su, grub-install to put grub back.

Kind of a brute force approach, but I agree.

When on windows, the command to restore your MBR is Fdisk /MBR

It is mean to be an undocumented feature, but I believe it is the most well known feature of Fdisk, even more than the documented ones :smiley: