Some Objects not hiding from camera


As you can see from the image, some of my emitters are not hiding from camera. I have checked and triple checked that the camera ray is turned of for these remaining emitters. All of the others are hidden. Anything I could be missing?

And the strange this is, if I drag one of the emitters that will not hide to an area where they are hidden, it will then hide from the camera.


Yep, that’s pretty strange. Attach the blender file for great justice.

I think you are still in viewport render that’s why you still see it. Press f12 if you still see it. Move them to another layer. In Render Layer tab, choose layer that you need to render . Or in OUTLINER, uncheck rendering for each of objects.

I have them toggled to hide from the camera. So i want them to render, just be hidden from the camera. They still show up on F12 renderings too.

So, for the few emitters that will not hide from camera with simply turning of the camera ray visibility, if I also turn off glossy ray visibility, then they fully hide from the camera. Strange.

Hum, that’s what I was thinking…
What you see isn’t the plane , it’s the reflection of the plane into the objects.

You can really choose what an object influence on what, camera, reflection, shadows , diffuse ect…

Generally you want your light to show up in reflections as it create some specular highlight, but in you case , as the light is really narrow the object you may disable it as well.