Some problem with the diffuse channel

I have a weird problem with the diffuse channel allways rendering at full intesity in my game map. I’m using the engine materials with one light and i notice that specular works ok but the diffuse colors in any of the materials im using to light the little room.

Could someone help me find out is wrong with this (i’m using the preview 11):

It’s funny that if i change the blending mode to subtract or multiply instead of mix it changes something. It seems that the room is geting a full diffuse color from somwhere but i can’t find what it is.

Spent another couple of hours with this and I’m stuck with this problem. I think it’s something with the mesh data but i already have a toon of textured meshes and it took a lot of work to make them so i need to find whats the problem is with these meshes.

Could someone look at the blender file and give me an help with this, please?

I’m only using Blender Materials and remove the older UV window texture assignments, so you have to press NUMPPAD0 to view from the camera then P to see the textures. Theres also a Ipo associated to the light that changes its color so you can see the specularity channel is working on the walls of the room.

Hey elander,
The Mix setting blends between the first texture and the one below it. This is the only setting where it uses the color slider. So to adjust the intensity change the Col slider.

There is a really noticeable bug, like the one you are describing that effects the lighting when using mix. Currently there is no work around, aside from writing shaders to do the blending. :frowning: Note you can ‘basically’ get the same results with the other blending modes, so changing the blending to add/multiply would be the best bet, until this bug is squished.

The only other thing I can see with the blend is the material for the wall is set to ‘Shadeless’, which is causing it not to be lit…