Some suggestions, please.

Sorry about this, but I’m at a loss. Is there a way I can increase the resolution of my texture maps. Here’s my character:
http://img453.imageshack.us/img453/3520/tousenkaname3d1lw9.jpg
http://img207.imageshack.us/img207/883/tousenkaname3d2gw1.jpg
http://img128.imageshack.us/img128/9720/tousen1picvx8.png

All textures are powers of 2:
Body - 512
Face - 256
Arms - 256
Hair - 128
Visor/Scarf - 128
Katana - 128

Damn - No help from me except to say I wish I could texture like that!

Whoa, awesome character!! How many polys??

They’re not really all that. See, I made two versions of the model, high and low, then used Render Baking on the high-poly face and arms, and applied that map to the low-poly model. Like I said, not all that.

Character - 2251
Katana - 198

Kinda high for a Blender game model, but it can be reduced.

You said you wanted higher resolution texture for character, would you be able to post the texture flats? My guess is that you aren’t using your UV space well enough.

Also I’m wondering why have you split the textures up instead of having them as one texture, are you planning to have them swappable in game?

I personally haven’t tried render baking diffuse maps before, I usually hand paint the colours, bake A.O on a separate file and set it to multiply on another layer in Photoshop.

Also there is some colour banding on the textures, might have something to do with what format you saving your textures as.

Can’t flaw the model, other than to say i’m sure you could cut down on a few faces here and there.

The thing round his eyes is confusing, is it a bandanna? glasses? maybe if you made it more clear.

Also, personally I don’t think purple hair compliments the other colours on his outfit.

A very nice job though.

I’m not sure what you’re asking–if you want a higher resolution on your maps, why not just use your image editor to resize them? There’s no maximum size, and you can always use jpg compression to bring down its filesize.

Here: (sorry for the size)
http://img223.imageshack.us/img223/719/tk1aq8.png

See, I made separate parts so that I’d have more space for certain areas. Each part was exported as 1024x1024 dimension sizes and then resized after the maps were completed in GIMP. I tried different sizes and no matter what size I used, they all came out low-res in Blender.

This is the character:
http://img132.imageshack.us/img132/8828/tousenyj1yk1.png

His name is Kaname Tousen from the series Bleach. He has a very unusual style, but he’s still a nice character.

WEll the first thing I would do to help your performance is to put all teh small textures into 1 big texture

open the scripts window and look for:
image>consolidate into one image.

that will put everything onto 1 big image, after that look for dead space where you can increase the UV island sizes.

every thing on 1 image will give you a nice FPS boost :smiley:

Are you referring to the fact that the textures do not blend smoothly from one to another? That’s due to substandard or old video cards, not the textures or Blender itself.

So the problem isn’t Blender, then? Well, that sucks. See, I thought that Blender renders all textures low-res, no matter the size. I increased the resolution of the texture maps in GIMP, and everything looks fine until I apply the map to the model inside Blender. That’s when everything goes south.

The problem might actually have to do with Blender. Try turning off mip-mapping for your character. When Blender mip-maps the textures, you’re actually seeing a reduced image quality (probably an interpolation between the original resolution and the next resolution step down). This blurs the image, causing it to look less than desirable, but the upside is that mip-mapping increases the game’s rendering speed by reducing the resolution of textures on objects that are “far away” from the camera.

To turn off mip-mapping on an individual object, you must be using Blender materials. I like to UV map the texture onto the object, then add a material and give it an “Image” texture set to the image I used. When “Image” is selected in the Texture window, you will see a button labeled “Mip-Map”, which is on by default. Un-tic it to turn off mip-mapping for that texture. I imagine you will be much more pleased with the results.

Did you have a material turned on for this model? Perhaps you are seeing that materials application on the model with the uvmap.

Whatever you see in the image editor you should see that same picture in the image editor in blender.

Do you? In other words when you look at the image in blender uv/image editor does it look like the one you made?

Also, it is better to use .png to save them, instead of .jpg, etc.

In the character Im working on I use a 1024 for everything, except the hair. But I dont have a lot of details.

I did give eyelashes and something else their own images, however If I find more room I will move them to the bigger one.