Some wall has vanished - now found but without bumps

I’ve modelled a simple tholos (beehive house), UV mapped some simple image textures (light grey, a bit of noise, and some lines from the initial tga file) and made an interactive walkthrough by putting motion control on the camera (space to move forward, arrow keys to turn left or right).

When I press P the camera moves OK, but some of the wall of my house seems to have vanished (near the entrance) and the textures don’t show :(. They do show in a simple render, and the house is complete in the render too. I’ve packed the textures. It’s not a very detailed model but I don’t think there’s much point in proceeding when random bits of the model disappear.

ETA: updated blend file further down the thread with recent fixes but bump still a problem.

Short answer:
Flip your normals.

More detailed answer:
Normals are like arrows that point which direction your faces can be seen from. If they’re facing the wrong way (away from the camera) you won’t see your face. Usually for a mesh you want them to point outwards.

To see which direction your normals are facing:

  1. Select your mesh
  2. Press tab to enter edit mode and select all faces with the a key.
  3. Under the “Mesh Tools More” tab select the button labled “Draw Normals” make them bigger by increasing “NSize”

To Flip Normals Facing the Wrong Way:

  1. Select the object displaying incorrectly.
  2. Press tab to enter edit mode.
  3. Select the faces with normals pointing in the wrong direction with the right mouse button (or the a key if it’s all of them)
  4. Press the w key and then 0 to flip them.

Another Quick Method that Often Works:
Instead of step 3 and 4 just try ctrl + n. This tries to automatically make them all face outwards.

I just selected both the walls object and the roof and flipped all the normals and it looks much better. I’m not posting the .blend though as you’ll learn more doing it yourself. :wink:

Blendiac, thank you so much. I haven’t had problems like that with normals before. Now, how do I get my image textures to show in the GE? Or can one only use procedural textures in games?

Just to make quite sure I wasn’t missing something, I painted my wall texture bright red. It showed bright red in a render, but dull gray in the GE. Guess I’m missing some important step.

Have you applied GLSL?

I think I’m going to quote this reply in any coming thread with normal problems. This is a great explanation.

No, do I need to?

I can take a look at it. Why don’t you post an updated blend.

Duh, solved the texture problem - use Textured shading mode!!! when running the game.

OK, fixed normals enabled GLSL materials, using textured shading mode, and all is well except no bump. On the walls I’m using the same image texture for col and nor - the col shows, the nor doesn’t (in the GE that is, both show in a render). I have a GeForce GTX 280 video card. As before, space moves camera forward and arrow keys turn left and right. Will add detail when I can get textures to show properly.


CN-090405-P001-M001-001.blend (659 KB)

I’m sorry, but I don’t know a damn thing about normals in BGE

Unfortunately, at this stage, neiher do I. Using GLSL materials gave a better result though, so thatnks for that suggestion.

Well probably your graphics card doesn’t support it? I mean sometimes normals can be software driven, but in blender your graphics card must have that feature hardware accelerated.

EDIT: Again, post your blend

I posted it a couple of posts further back (#9).

Thanks, now I understand why I never see my normals having effect.