Sound Actuator problem

Hello everyone!
Recently I’ve encountered Sound Actuator issue in Blender 2.73a. When I try to feed it with sound file via Open button and selecting .mp3 file I get error: Unsupported audio format. This doesn’t happen when playing sound with Python script and aud module.
I would be grateful for any help in this matter.

Edit: I’ve noticed that this situation doesn’t happen if I load audio file in empty, default .blend file. Now I’m confused.

You haven’t mentioned what os you use. I have seen nothing audio problems any Blender version. Not Windows and not Linux.

Try different soundfiles, your audio may contains corrupted mp3 chunks. Or try to convert your audiofile to wav or ogg format.
(Audacity, free software is very flexible)
Remember too 3d sound option needs mono track.

Heh, you edited while I has writing this…
Hmm… Have you changed audio driver, if you are Windows there are openAl and SDL, I think SDL does not support 3d audio.
Restart Blender may test too.

This has happened to me once before, just use a program like VLC media player or Audacity, load the file in and export it to the chosen format (I personally recommend .wav).

Problem solved. What I’ve done was to simply create new file and append everything from the old one. The Sound Actuator worked properly in that case. My system is Windows 8.1 64-bit, if someone still wonders.
Thanks for help, cheers!