sound format problem


(d52477001) #1

hi,

i have a whole lot of .wav from microsoft cliop gallery. yet, if i want to load on of them into blender, it says that it is not a valid sample. i have only found about 3 or 4 that actually work. is there any way to make these sounds work in blender? if not, is there a good site where i can get free sounds?

thanks

d52477001


(wes1) #2

Check http://www.3dcafe.com

or one of the links on http://www.blendergames.com/links.php below the list you can find some about music sites.

wes1


(cluh) #3

how i get the non-working sounds to work is open that non working one and a working one in a wave editing program, select all of the non working one, paste it over the working one and save that as a new file


(d52477001) #4

cluh: very clever!! and it works :o . its amazing how many sounds i now have at my disposal… :smiley:

thanks a lot!! 8)


(digitalSlav) #5

why paste - you just have to open and save with different specs.


(doogs) #6

More matured question:

What are the specs needed for .wav files in Blender? Also what are the specs required for MP3 files in Blender? Why aren’t these in any documents?

Thanks

-Doogs


(z3r0 d) #7

Are you using creator 2.23?

(I have problems with it)…
For myslef sound works best in the (2.25) plugin.

Well, anyways, your sound should be PCM mono, as far as the bitrate it doesn’t seem to manner. If you use stereo sounds it will not be possible to do the 3d ‘location’ effect…

Blender supports Mp3? I doubt it, especially considering that now the royalties are applied to EVERYTHING, even players. I think somebody had a script for it though.

Conversion, using sndrec32.exe (in windows directory, or windows/system32, or accessories in start menu, or a possible subdirectory of the previous)

  1. Open your .wav file
  2. go to file, and choose Properties
  3. Click the convert now button (you will set the conversion settings next)
  4. Set the format to PCM
  5. Set the Attributes how you would like (Higher bitrates ex. 41.000khz, and higher samples 16bit sounds better, but is much larger, for onine games go as low as you can with ‘acceptable’ quality. You will have to give up some if you want a small file)
  6. Click Ok (to exit conversion dialog)
  7. CLick Ok (to exit properties dialog)
    The file is now converted, and you can hear what it sounds like by pressing play.
  8. Go File, “Save as,” and save as a NEW file. (or you can overwrite the existing one, but I suggest you don’t do that)

too simple, just lots a steps


(saluk) #8

Uh, yes, blender 2.25 DOES support mp3’s, using the free fmod.dll file. But in the future, mp3 is going to be anoying charging for the technology in players, not just recorders; so we’ll have to switch to a free codec such as ogg vorbis.


(Pooba) #9

Yeah, i think the mp3 may have to be mono, not stereo, but i’m not sure…

Pooba


(gorgan_almi) #10

Does anyone have a script or plug-in that’ll allow Blender to play .mus or .mid files?

Failing that does anyone know where I can get a mus/mid-to-wav conversion utility?

Thanx all the same.