Sound in 2.58

Question, how do i get sound into my animations using Blender 2.58? is there a window or something becuase i cant find it. i am used to the 2.4 setup. Any words to the not so wise?

Set the view to ‘video sequence editor’. If you’re not sure how, see the 3rd image on this page:
From the Add menu, select Sound. This version of Blender doesn’t seem to export sound except for a very limited set of formats, so I tend to do all my mixing in Audacity, export as a single file and import that into blender, to make sure the sounds are correct. Then I export an uncompressed AVI and use VirtualDub to compress and add the sound.

Since you’re more used to 2.4, you might find this page useful:
I only started with 2.5, and that site really helped me get to grips with the interface.


Now how to i render the animation with the sound in it? I got the strip in but i can’t render it with the sound. Any advice?

Choose a format that allows sound. I’ll use Xvid in this example.

Set the output preset to Xvid.
Under the encoding tab, keep the defaults but up the bitrates:
Format: .avi
Codec: mpeg4.
Bitrate: 14000kbps
GOP: 18
Minimum Rate: 9000kbps
Max Rate: 14000 kbps
Buffer: 1792
Rate: 10080000
Packet Size: 2048

Choose your audio codec, make sure it is supported by the codec you are using. I’ll use MP3, bitrate: 192kbps, samplerate: either 44100kbps or 48000kbps.

Another option is to use the same settings but encode using Xvid, .avi, and set the codec to mpeg2. Then set the audio codec to PCM. This will get you a high quality audio stream.

Then you can use ffmpeg to strip out the audio like this:

ffmpeg -threads 2 -i mymovie.avi mymovie_audio.wav

change -threads 2 to however many cores your computer’s processor has or just leave it out.

Once you have the audio in it’s own file, then you can use an audio program to clean up your sound.

When your newly mastered sound track is ready to put back into your video, use ffmpeg again like this:

ffmpeg -threads 2 -i mymovie.avi -i mymovie_mastered_audio.wav -map 1.0 -map 0.0 -vcodec copy -acodec copy mymovie_final_edit.avi

Thank you
-EDIT: The sound works great thanks. one problem again. (sorry, i’m not the best) I get the audio but no video. Any help? thanks.

Is that “no video” just a black screen or no video to display at all? It would be really helpful for Blender to actually output sound only files.

Is Sequencer turned on in the Post Processing panel of the Properties menu?

I play them through windows media player so it is the swirls and stuff and yes sequencer is turned on. Any help is appreciated.

So no video but great audio when i render the animation.

Media player will do the swirls thing if it can’t find an appropriate codec to pull up vision. I think that you may have managed to make a faulty video file. Not sure why you get black only though.

Thanks any way.