sound in animations

Hi guys, I’m new to blender, tell me what I’m doing wrong here:

I cannot get sound working in my animation! Format is set to ffmpeg, video is mpeg-2, and audio is mp2 (with the multiplex audio activated).

In the sound block menu I added my sound (a .wav file that works fine in VLC and when I press the play button in sound block menu). The sync and scrub options are activated. And in the Audio Window i it appears correctly.

But animation has more than 900 frames, and if I render 100 (i have 25 fps) frames to see if all works, there is no sound! What’s wrong?

Thanks in advance,


First of all, what Blender build or release are you using? (I’m using the latest 2.5 builds from Graphicall and 2.49)

Secondly, sound does not show up during render time. It appears in the file generated as far as I know. Have you tried playing the file it actually rendered?

If the sound is working during playback (which you didn’t explicitly state, but it sounds like it is), then you likely didn’t enable sound for rendering. Next to the codec tab in the render options an audio tab will appear when ffmpeg is selected. Click on the tab and then enable “multiplex audio”.

If sound is not working during playback then make sure that you are importing the audio file into the video sequence editor as an audio strip. This will also allow you to easily time the audio to the animation. I don’t really know what the audio window in blender is used for, I haven’t found a use for it…

Thanks for your answers!

I forgot to put my sound file in the video sequence editor, now it all works great :slight_smile: