Sound problem in Blender VSE in Linux

I asked this question on another thread to no avail, since that was a Windoze thread I thought I’d post a q specifically for Linux.

I’m rendering a timelapse in the VSE. I added a music .wav file for sound, but the final output has no sound. I’ve been rendering it as avi jpeg. I read a couple of threads about this, said I needed ffmpeg, so I used the “add software” function in Fedora 9 to add “libraries for ffmpeg”. After a restart, I still don’t have ffmpeg as an output option in Blender.

I don’t know what I’m doing wrong and would appreciate any advice. Thanks.

Hi!
in terminal :
$ ffmpeg
output will be somthing like:

ffmpeg version CVS, build 3276800, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --extra-cflags=-DRUNTIME_CPUDETECT --build x86_64-linux-gnu --enable-gpl --enable-pp --enable-zlib --enable-vorbis --enable-libogg --enable-theora --enable-a52 --enable-dts --enable-dc1394 --enable-libgsm --disable-debug --prefix=/usr
built on Jul 23 2008 21:50:12, gcc: 4.0.3 (Ubuntu 4.0.3-1ubuntu5)
usage: ffmpeg [[infile options] -i infile]… {[outfile options] outfile}…
Hyper fast Audio and Video encoder

If not …install ffmpeg .After that :
Try :
Format panel> FFmpeg
Video panel> Format: ( from pop-up choice) AVI
Codec: MPEG4(divx)
press Autosplit Output button
Audio panel> press Multiplex audio
leave Codec:MP2
All the best!

Thank you! I’ll try that when I get home tonight and see what happens.

Well, it looks like ffmpeg is installed:

[eric@localhost ~]$ ffmpeg -format
FFmpeg version SVN-r15261, Copyright © 2000-2008 Fabrice Bellard, et al.
configuration: --prefix=/usr --incdir=/usr/include/ffmpeg --libdir=/usr/lib --shlibdir=/usr/lib --mandir=/usr/share/man --arch=i386 --extra-cflags=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -D_ISOC99_SOURCE -D_POSIX_C_SOURCE=200112 -fasm -std=c99 -fno-math-errno --enable-libdc1394 --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-x11grab --enable-avfilter --enable-avfilter-lavf --enable-postproc --enable-swscale --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --disable-optimizations --disable-stripping
libavutil 49.10. 0 / 49.11. 0
libavcodec 51.71. 0 / 51.71. 0
libavformat 52.22. 1 / 52.22. 1
libavdevice 52. 1. 0 / 52. 1. 0
libavfilter 0. 1. 0 / 0. 1. 0
libswscale 0. 6. 1 / 0. 6. 1
libpostproc 51. 2. 0 / 51. 2. 0
built on Sep 17 2008 20:49:54, gcc: 4.3.0 20080428 (Red Hat 4.3.0-8)

But I still don’t have it visible in my format list, see the screen shot. Any ideas? I’m confused now. Should I reinstall Blender?

Attachments


Yes, you need to download ( http://www.blender.org/download/get-blender/ ) and reinstall blender… for some reason you have a version that was compiled without ffmpeg support.

of course, you could try one of the new 2.49 RC builds… :slight_smile:

Agree with paprmh…go to Blender-homepage and install again.
Note that ,your arch=i386 (according to your ffmpeg configuration ) !From homepage install proper Blender 2.48a, Python 2.4 (13 MB) or Blender 2.48a, Python 2.5 (14 MB)
corresponding to Python.
Good luck!

OK. I downloaded and unzipped the tarball, ran the exe and now I see ffmpeg as an option. I’m rendering right now, we’ll see what happens.

I did look at the repository info, since I’ve been using the livna repository, and it specifically states that the version of blender provided does not include ffmpeg support.

Thanks for the help!

Success! That worked, thanks for all the advice! I’ll post it to my YouTube channel (user name: teelaklaatu) soon. Now that I’ve seen it with sound, I think I want to edit it a bit more.