Sounds

How do I stop a sound? Basically when I put a sound on an object it continutes to loop. I dont understand why.

Use the Loop stop function instead of loop end

If you’re using an Always actuator, that could be your problem. If it’s set in “True” pulse mode, the sound will repeat no matter what the sound setting. Change it out of True mode be un-clicking the “clicked” button in the upper left-hand corner. (should have three little dots at the top of it.)