Hey, im i have a space texture for the world, but whenever i select the texture in the world settings, it doesnt change the world at all. It just stays blue. What am i doing wrong?

Your probem is simple: GO to the world settings box. You’ll see two tabs. Textures and Inputs, and Map To. In the “Map To” tab, click the “Hori” tab. Your texture will be enabled!


(Glad to be of help.)