Specular Artifacts

Anyone know what I can do to get rid of these?


I’m rendering in blender internal, with an angle map for reflections. I have 1 hemi light with no spec to help lighten liquid. Spec and Hardness are in the mid range.

I take it back, they arent specular artifacts… it has something to do with the transparency or the reflections. I removed all the lights from my scene and they are still there, and changed up my specualr settings and nothing changed.

Ok, I’ve narrowed it down to transparency, and it seems to have something to do with IRQ… It’s set at 1.2 and I’m still gettings artif

good grief… ok… the ones on the rim are caused by Ray Mirror, and the ones at teh base are caused by Transparency… /sigh. I’ve tried increasing the raytrace resolution and the levels… no change.


Have you got an HDR image as your angular map? If you have, increase the Filter value in the image texture settings.

Thanks Rawpigeon. I tried it, but I’m still getting the artifacts

could you possibly have extra geometry there?
have you tried removing doubles?