Speed Vector Pass not working

I’m trying to do a vector blur with composite nodes.
For some reason I’m getting NOTHING from the speed output of my render layer. Just a blank frame with zero alpha.
(To get some simple questions out of the way, YES the objects are animated and YES I have “Vec” selected in my render layer)
Thing is, I’ve done this before and it’s worked fine. I even opened up the old file where it did work to try to see the difference, but for the life of me I can’t figure it out.
Has anyone else had this experience?

It’s working for me here. You can have a look at the blend file in my other post about a bug in vector blur here.

You can get the rar file of the blend file here
Check out the node and render setup in there and hopefully that’ll help.


I think I ran into this problem one time and I had to turn “on” the full OSA button on my materials…I had certain parts of an object that would blur and the other would not, and the only difference was this setting in the two different materials…may not be your solution though…

Wasn’t. But thanks.
I ended up opening the blend file I already had that worked, deleting all the objects and appending everything from the file that didn’t work.
… that worked, but I still have no idea what the problem was.
Must’ve been one of those too late and too tired things.
Anyway the job’s done and played out.
Thanks for trying to help out.

Enable Vec in the Render Layer. It’s not on by default.

… while I’m will ing to accept it is probably something simple I overlooked, this isn’t it.

just double-checking, you know, these things have a way of unsetting themselves for the renderlayer you are using.

is the camera on an active layer?

I’ll have to check again when I get to work on Monday. I’d really like to solve this one, even if it means admitting that I’ve made a really simple mistake.

For any Aussie blenderheads out there, you can now rest assured that a lot of the graphics you will see this year on the game show “Temptation” were made in Blender.:slight_smile: