Sphere shading in GE with GLSL

I’m trying to make a pool game with Blender 2.57 and I’ve finished everything except for the balls. Icospheres and UVspheres both do not shade correctly when I actually start the GE.

I tried making a cube, going into edit mode, deleting all the vertices and then adding a sphere in the cube mesh. That worked the first time and the sphere shaded correctly but now as you can see in the above picture, it no longer works. Can anyone help me with this issue?

have you added a material?

you should learn the basics before start to make a game believe me, i tried without it and It led me nowhere, try to learn the basic functions of blender, how it works, witch shading modes you have. In your case there is no materials aplyed to the balls as loui said. to create a material just press the add material button on the shading panel. But for a game you ll need to create a texture for the balls, then create a UV map.
try this website, www.blendercookie.com.
Good luck

K thnx, I’ll try that, again but with the UV textures added. But why do the other primitive shapes shade correctly with or without materials and the sphere based primitives don’t?

Here is a picture of the spheres again and the white one is the one with the green material applied. Now all of a sudden the other sphere’s without materials are shading correctly which is what they were doing before. This is before applying a texture and UV map. It also has not been put into textured mode yet.

Just a note, I’ve been using Blender for more than a year now, although I initially started with 3ds Max 2009. I understand the basics of how Blender works, I just haven’t messed with the GE much until now.
Thanks for the link btw, that should help.

Have you actually enabled GLSL shading in the N-key panel, it looks as if you might not have because the pool ball materials should show up in the viewport if it is providing the image is set to use UV-coordinates

Yes, the textures show up in the viewport normally. The pictures I took are taken while the GE is running.
Here’s a pic,

Is there a quick and easy way to fix the way Blender is rotating the image I’m using as the a texture to make it look right on the back part of the pool ball? I don’t want to have to edit the image itself and then change the mapping again to get it to look right.

Here is the actual texture-

Here is the front and back of the ball-

I don’t want it to mirror it on the X-axis, I would like it to just copy the texture onto the back as it is. Would I just change the size on the X-axis under mapping to > 1?

It seems to only be wrapping the image around half of the sphere and reflecting it on the opposite side. I tried using UV mapping to get it to show right on both sides and checked the face textures box and they still won’t show in the GE.

Have you tried changing the way you UVmapped the texture?

For a sphere like the pool ball I would just have a seam running the center loop so you get two sections and thus having two halves, both centered on the number.

Then overlap the sections and expand them so they take up a lot of the space surrounding the number, that way you can rotate each half to orient the number to how it’s supposed to be.

Wow, thanks Ace Dragon. I can’t believe I UV textured anything without seams. That should work perfectly. :slight_smile: