spin making faces all of the sudden.

Here are my steps

create a circle (KEY A, >Circle) change the default 32 points to 6
change to top view (KEY 7)
drag circle just above cursor in top view (RMB)
go to edit mode (TAB)

select circle (RMB) select Spin in the tool palette
change the steps to 3, degrees to 360


where do these faces come from?


might need to set dupli in tool panel!

happy bl

I see.
but did something break in 2.71?

What do you mean?

When I did the steps in the 1st post on previous versions of Blender I never saw that result, not until I upgraded to 2.71


Are there any differences?
To the protocol :wink:

Spin spins around the cursor from the current view and connects each vertex to its duplicate, making faces, unless you check the duplicate checkbox.
It looks like a mess because you are spinning around an axis that is perpendicular to the face of the mesh. if you were to go to right or left view for example and spin it what its doing would make sense…


If you just want two duplicates of the hexagon you are using the wrong tool for this. Just shift D, rotate 120d, and repeat. The spin tool is not the rotate tool. It really should be called lathe to avoid these confusions.

What happens is that in Blender 2.49b there were 2 tools in 2 buttons, “Spin” and “Spin Dup”

Blender 2.71 has those 2 tools in only 1 button , “Spin” , by default when you press the button you get the same effect as “Spin” from 2.49b.
To obtain the same effect as “Spin Dup” from 2.49b, you need to enable “Dupli” in the operator panel/F6 after pressing the “Spin” button

Ah now I remember… that was back before computers and the internet and stuff like that… had to run Blender on the kitchen counter…

more like entering code on IBM cards and getting results on TTY sr-33!LOL

happy bl