Spot Lamp Halo Bug?

I think I, along with a few other users, have noticed a bug in the way Blender deals with halos on spot lamps. Here is a pic to demonstrate what I’m talking about:

Basically its a scene with four planes with different colored materials that meet to form part of a cube, inside of which is a cube with similarly colored faces. Each face has “emit” set to a value of 0.158 simply to show there are walls there. A spot lamp is place OUTSIDE of this “room” and its “Halo” is turned on for that one lamp. No other lights are present in the scene at all. With halo turned OFF, the scene renders with just the walls very faintly lit (due to the emit property). However, with the halo ON, as you can see the entire halo passes through the wall, lighting the surfaces beneath with whatever color the spot is set to. Now…tell me if I’m wrong, but shouldn’t this simply not be happening?

here is the dotblend so you can see how I’ve set it all up if you wish. This effect IS reproducable.

Desoto, you could try this.

Click the Shadow button on for the Lamp and in the render buttons if it’s not already pressed.

Also the settings for the volumetric sampling frequency will/may need to be tweaked.

This should then eradicate the problem. But I have encountered it before.


You need to put halostep different than 0.

Smaller is better but more cpy hugging.


There is a lighting tut in the standard docs. It goes into some detail regarding spots. Worth a read.

Well paint me orange and call me oompa.

That was just the trick. It seems like every time I think I’m really onto something I just turn out looking like an idiot…

well, you will look like an idiot if I paint you orange, no doubt about that :wink:

glad I could help