Spotlight help please.


(hotsnoj) #1

How do you get the spotlights to act like real spotlights? here is a pic I’d like you to see…for an example.

hwcomic.planethardwar.com/test%20renders/shadow_test01.jpg

So how do I stop the light from going thru the ship or any other object? As to make a shadow.


(S68) #2

For shadows, you must enable the ‘Shadows’ rendering button

For the halo light in the spot, nothing to do. Blender isn’t a raytracer.

Only way (veeeeery CPU intensive and pretty complex) is the following hach of mine from a eeshlo technique:

1 - Search for eeshlo homepage and learn his DupliFramed plane technique.

2 - Use it

3 - From the ship onwards so as follows:

4 - Change the DupliFramed object to another object lacking the place where the shadow is (or change the texture;)

5 - Go on with Dupliframes

I know this is higly unclear, but It will be clear as you proceed :slight_smile:

Stefano


(hotsnoj) #3

Never mind then. I have a P2-266 MHz CPU with 64 MBs SDRAM, so I’m pretty limited to waht I can do.


(RipSting) #4

No no… You CAN do this… You just can’t have the halo be textured, which is what Eeshlo’s method accomplishes.

You need to enable Halo-Step in your lamp!

Step-by-step:
1)Click the ‘Shadows’ button in the display buttons window (F10)
2)Create a lamp and make it a spotlight
3)Hit Ctrl-0 to view through the lamp
4)Adjust the ClipSta and ClipEnd properties so that the shadow-casting object is visible
5)Click the purple ‘Halo’ Button
6)Make the ‘HaloStep’ != 0 (1 = best quality, 12 = worst but fastest quality)
7)Increasing the ‘BufSi’ property increases the resolution of the shadow map.
7)Alt-0 brings you back into your camera’s view
8)Render!


(hotsnoj) #5

I’ll try this right away. THANX A TON!


(S68) #6

Yup, but thats works only for convex objects :slight_smile:

Stefano