Spotlight pattern renders on skin but not other materials

I’m certain that there is a setting of some kind that I can ‘flip’ and I will have my pattern on walls and clothes, but on the moment, it only shows on my character’s skin.

I’m running 2.68a on Windows 7.

The pattern is projected from an image imported as a plane and with the clothes layer not showing, the character has the pattern exactly like I want it. With the clothing on, the pattern is present on exposed flesh.

The clothing and the floor have a texture and this renders fine. Everything looks exactly like I expected in the other camera, but the spotlight pattern is turned off for that camera. Shadows from other lamps in the scene render OK on both the cloth and the walls and floor.

I’ve tried searching on this, but nothing seems to have the information that I need.

Does anybody know that setting?

The material shadow needs ‘Receive Transparent’ checked.

'Tis a pity that I don’t have more hair. Then I could spend more time solving problems instead of whinging to the Forum.

Ralph