star size consistent despite time?

I’ve made a short particle simulation, baked it and used the Time IPO to freeze it in place. The only problem is, the particles are of a definite size and I can’t get Size or E_Size IPOs to work so the stars are always the same size while rendered!

If there’s a shortcut to making particles always appear to be the same size, no matter how far away the camera is, I’d love to hear it. Otherwise, I need a way to make the camera’s parent’s size a driver for the IPO channels I listed above even though I slowed down time to a standstill. Any suggestions? :confused:

The only way to do that is to set your camera to Orthographic (F9). You should render these stars from another scene if you need dpth perception for other objects in the scene because ortho renders lack depth. It looks the same as viewing the 3D window and pressing NumPad5.

You probably won’t like the result.

Attachments


I actually discovered I can control the size of the halos using HaSize in the material IPO. Doubling the size of everything helped in keeping the stars small.

I’m still having problems using the IPO to change the halo size based on the time!

Attachments


a big thank you to whoever can figure out why the IPO isn’t working like it should. At the frame where the green line is, the stars aren’t showing up at all! Adding more points doesn’t seem to help. I used global time in the time panel to hopefully override the time IPO I used to freeze the stars in place. Any suggestions?

To recap:

I want the stars to grow as the camera gets closer. Seeing as how using an object driver did jack squat, I decided to do it based on the timeline. I have the Time IPO keeping the stars frozen, and hopefully the global time settings will override that. But the stars are not shrinking slowly like I hoped. Help!

Attachments


I guess halo size is not relative to camera (same size everywhere). Can you link it to an empty and animate the empty over time?

I tried using the same empty that controls the distance of the camera to the galaxy as the driver for the size of the haloes. No luck.

Here’s the file, hopefully you can fix the problem.