Stars in Animation


(darkstar1) #1

How do I get my stars to stop “blinking” in my animation? I’m using StarDist=4.00 MinDist=0 Size=0.07 Colnoise=0


(S68) #2

1 - MinDist=0 is among the worst choiches. This is the nearest star to the camera distance. You very seldom want a STAR in between the camera and your objects. So set this to a greater distance that your farthest object

2 - StarDist=4 is fine, but I prefear to set ClipEnd of Camera higher than to set stars closer to each other. it is better for the results

3 - Once you’ve set MinDist high you can set starsize higher, this should make them les blinky :slight_smile:

BTW, I love if some stars slightly blinks :slight_smile:

Stefano


(RipSting) #3

Make sure you have Oversampling/AntiAliasing on! It’s the OSA button in the display buttons (F10). The numbered buttons below it (5,8,11,16) corrospond to the number of samples. 8 is Generally a good number.

If you want you could also turn on Motion Blur (the MBLUR button to the right of OSA). If you use motion blur, you generally don’t need OSA. Again, the numbered buttons = the number of images rendered per frame.


(darkstar1) #4

Thanks, I raised the clipend value and stardist, also the mindist was 8 not 0 so i still raised it. The end makes the stars look good and I kept a few blinking. :slight_smile:


(0ptikz) #5

Hey dude,

I had exactly the same problem as this when I rendered any animations with stars. I then realised a few months later that the reason for the blinking stars was because I rendered to “Avi Jpeg” instead of “Avi raw”

It would seem that the jpeg compression has a problem with renderin’ stars :smiley:


(0ptikz) #6

A bit more info:

If the “avi raw” raw option solves your blinking star problem but you still want the anim to be compressed, use Virtualdub and compress yer anim with the divx codec…

http://www.virtualdub.org/index

Hope this helped.