Stars that don't flicker when you rotate the camera??

Basically that’s it, does anyone know a way of doing this??


What version of Blender are you using, and what are the parameters for rendering the animation? I just ran a quick check with 2.31a, and with the animation set for 90 frames (3 seconds), NTSC, raw AVI, no OSA, and no MBLUR I see no flickering of a starfield when rotating the camera 360 degrees in any direction.

Thanks for the swift reply,

Sorry, should have been more specific.

By stars I mean stars that appear as though they are millions of miles away (ie: a few fractalled spheres with halo’s of different sizes as the material, parented to an empty with a copy location on the camera.) OSA must be on, (which is what I think causes the problem) the stars must be small ~1 pixel (also the problem). A rotation with this setup will cause the stars to flicker.

What I need: Stars that are invarient with camera displacement, but not rotation, are behind any planets/stuctures I need to place, and look real.
OSA on is a necesity, unless mblur is on.

I am using Blender (the latest) wth Raytrace etc… or any Blender version prior that I need to use (I have them all).

(for testing, if the motion is too fast flickering may not be noticable, I need a method that has no noticable flickering for slow rotations.)


so, you aren’t using the star settings in the world buttons?

I’ve made a sphere that emitted particles in random directions (with quite a speed that they may vary in size), but the stars in the world buttons are pretty good.

Try turning on motion blur

also, try rendering at a higher resolution if your stars are too small

Thanks for the reply…

The stars in the world button move past the camera and appear in front of objects, even with the furthest distance settings. Thus they are useless for my purposes as real stars are very, very big, just a long distance away.

Any other ideas??

If the stars are too small they get less than the size of a pixel and flicker. Camera clipping distance can help here too.

unified renderer button in the display buttons, press it

also, adjust the star distance settings (because they really are in front of your objects) in the world buttons (you want to adjust MinDist)

Just as a side note, I found Blender’s starfield not to be as convincing an effect as using a cloud texture as per this tutorial: