Start of the new strand renderer (go Brecht)
(near the bottom)

While not raytraced yet, this is a significant development in strand rendering, please note it just started so a lot of changes is likely and still has issues. So be prepared to drool over the strand render pictures when more interesting ones are released.:yes:

Ok so the new particle render will be better, but will it be all that much faster?

Hurray! This is excellent news.

not only is the shading heaps better… it is incredibly, mind bogglingly, outrageously fast!
(5 million hairs in 40 seconds… booyah!)

brecht rocks.


ps: ok ok i have a workstation with 8 cores and 8 gig of memory too… but the point still stands. :slight_smile:

5 in 40 secs? sweet !!!

Wow. Brecht=1337 Belgian guy. (all the other coders are 1337 too ;).

That’s awesome!

wow!!that will be amazing…
I’m sure everyone will enjoy that. :eyebrowlift:

Dude… you need to put a warning sticker on that kind of information! My jaw drops so hard I chipped a tooth!!! :smiley:

Wow thats friggin intense. Well I only have 4 cores and 2Gb of RAM but hey it should still be interesting.

brag on, douchebag! :eyebrowlift2:
im stuck with my single core, 2 Gb ram beast at home…

re: strand rendering, the test renderings look awesome! cant wait for it to progress and start using this bad motherf

is their anyway to try this out now?

whee !
real grass !
real trees ?

“Real” trees are part of the Peach project - they are making a foliage generator script - so the answer to that is “Yes”

where can I download this please?

It looks pretty darn impressive and easy to use too. I cant wait tot ry it out.

burns: It’s in svn, so all you need is a recent build, I think the latest is probably at

About the new strand render it does look really quite amazing… and fast too!!

It’s nice, but if you’re going to try: do not forget to press that strand renderer button.

If you start with the default cube, add hairs, make the particle hair have child hairs, and then render, Blender will suck up all your main memory because the default particle child setting is to have one hundred hairs for each guide.

Just a small warning. Perhaps it would be a good idea for the developer(s) to change this behavior :slight_smile:

Very nice…

Does this fix the issue with the strand widths not changing with distance properly?
<insert proper description of well known problem with current strand shading here>

Even if not, this is a huge improvement I’m going to really, really appreciate. Strand rendering of hair causes the biggest slow down in all my renders right now.


P.S> I’ll have a lot of fun testing this after my last exam this morning!

I’m testing a bit the new hair particles,the speedup is really good,not only rendering,but even the combing of hair is good,fantastic.
For now it seems vertex groups are broken for painting lenght,density and so on,someone succeeded in that?