Still Can't Get Cycles to Work

Hi, just trying cycles and can’t get it working. I downloaded this cycles version http://graphicall.org/144
for Mac OS 10.58 64 bit and I am using Mac Pro Tower Os 10.58. NVidea GT 8800. If anyone is using a similar setup, please tell me what build you are using.

Problem
I added a material to my plane and set it to “Emission” but when I set the viewport shading to “Rendered” the plane isn’t lit up? (there’s no light)

Here’s the file.
https://rapidshare.com/files/2625285779/cycles_01.blend

Here’s my settings.

Renderer is set to: Cycles
Set plane to: Emission
Selected the monkey and added a new material and set it to: Diffuse BSDF
Set the shader icon to: “Rendered”

I still can’t get this to work. Any help is appreciated. http://bafull.cgcookie.netdna-cdn.com/images/smilies/sago/smile.gif

pg

When you opened blender, did you reset the factory defaults so you started with a base scene with the 2 lit monkey heads? Does that show correctly with the renderer set to cycles and in rendered view mode.

@Paint Guy: If you use P to separate the planes into 3 objects, the material works. Bug?

Hi Richard. Yes I did that (see image) but I still just get a totally black screen. I made sure the renderer was set to “Cycles” and I set the view mode to “Rendered”. Do you have a very simple that works for you that I can try to see if it works. Are you on a mac with my same specs? If so what Cycles Build are you using?


Thanks CD38. Yes I tried with the light planes separated and with them as duplicates and it still renders totally black.

From a Graphicall build note:

"…If you get blank renders then you’ll need to start blender like this (or see below):
export DYLD_LIBRARY_PATH=/path/to/oiio/dist/macosx/lib/ ./path/to/bin/blender.app/Contents/MacOS/blender

(don’t forget to replace /path/to with the actual path to the folders!)
Or just copy the included libOpenImageIO.dylib to /usr/lib and then start Blender as usual.
Additionally you’ll currently need the required dependencies to run the build. Download MacPorts. You’ll also need xcode installed to run Macports. Once you’ve done that in the terminal type the following:
sudo port install openexr boost cmake hdf5 tiff jpeg
Wait for them to download and build.
I didn’t include the libOpenImageIO.dylib this time. I assume most will already have it. If you don’t I’ll upload the file somewhere later and you can get it from there."
This is from a non-Cuda build but may list a dependency that you may need.

Thanks ajm. wow that looks complicated and I’m not sure where to start. :frowning: Why do I need to do this? Is it because my computer doesn’t support the correct graphics card or something. Does cycles not support Mac OS 10.58 or something? Can you explain the steps in layman terms like:

  1. do this
  2. do this
    etc.

I ran into the same problem on OSX, no joy. But it does work fine on Windows and presumably Linux.

No Joy is right.:frowning: I hope this is something that will be fixed for us Mac users before it is implemented into Blender Trunk. :slight_smile:

Really surprised. I thought there were more Mac users on this forum using OS 10.58.

Not sure what to say other than I would just start at the top and work down. From the “or just copy” part on. Basically I found that Linux and apparently OS X doesn’t have the libraries pre-installed to run cycles. I don’t have a Mac, but I dual boot Windows 7 and Linux, and Linux requires you to download and install several libraries so that it can export the geometry and then stream the data as far as I can tell, not just for Cycles, but Lux and Yafaray as well. They work out of the box with Windows, aside for openCL stuff that AMD has now packaged with their drivers.

It’s not really and issue with Cycles as much as it is the lack of resources of the OS and the libraries needed to run it.

I would do this.

  1. copy the included libOpenImageIO.dylib to /usr/lib *
  2. You’ll also need xcode installed to run Macports
  3. you’ll currently need the required dependencies to run the build. Download MacPorts.
  4. in the terminal type the following: sudo port install openexr boost cmake hdf5 tiff jpeg
    Wait for them to download and build.

*According to the poster the .lib that he mentioned is not included with the builds, but you may find it somewhere. That’s all I know.

Applications for Windows are packaged with all the support libs they need, making them relatively self contained. The downside is that you end up installing the same libs over and over again with each application. Linux applications all use the same single install of the support libs, which saves space and RAM usage, but means you normally install them separately.

:slight_smile:

Yep, which just means that with windows, there can be a lot of stuff installed with your system, that you may never ever use but it’s there “just in case”. Nice idea, but I wonder how many DLLs are there that can be thinned out.

Thanks organic. Thanks. Yes seems Linux has a much better way of doing it. I wonder if it would just be easier to install Linux alongside OSX and then run the Linux version of Cycles. Then I could just run the Linux Cycles Build without installing anything. :slight_smile:

Thanks for explaining this ajm.:slight_smile:

  1. #1 says “copy the included libOpenImageIO.dylib to /usr/lib *”. I found “libOpenImageIO.dylib” in the Blender application folder but can you please tell me where the /usr/lib is located? I don’t see a folder for that.

  2. Is this long painful process only temporary until it is in the Blender Trunk. I mean if this is what I need to do to render an image then I’d rather just use the Blender internal. Please tell me I can just render and I won’t have to do all these installation and steps in the future when Cycles is added to Blender Trunk. :frowning:

  3. Why can’t the mac build of cycles at graphicall.org just include all of the dependencies in the build like the windows version so we wouldn’t have to do all of this setup. Is this possible?

Like I said I run Linux and Windows, so I couldn’t tell you where the /usr/lib folders are in OS X, it could be under your [main drive]/usr/lib like Linux but I really don’t know. In answer to your second question, you should only have to do this once and never again, and all cycles builds should run after that. This installation process just installs libraries that stay on your system so that things like this can run. Your third question is a good one, but then again Linux users go through the same thing, but installing libs from the terminal or Synaptic is much easier. I suppose they could include libraries though.

Thanks AJM for your patience and very helpful replies. I will do my best to work through this. :slight_smile: