Still noisy after 20480 samples :()

So I’m strugglin’ to reduce noises of this image:

I stopped rendering after the right half is finished. I can still see noises at around the upper right corner.

I have tried a lot of tech to reduce noises. I increased the size of that point light to 1 cm, used filter glossy of 0.5, added a light portal at the light bulb, facing to the floor, also selected the “limited global illumination”. The sample is as high as 20480. So I wonder if I’m missing anything? Or what is the regular sample I need to render an interior image like this?

Note: There is a light bulb with a point light in the middle as you can obviously see, and there are also 3 other same light bulbs without light. The light bulb use the glass+transparent mixed shaders. Everything else is just the chair model.

I appreciate your help!


Well it might be hard to notice that noise, but in the original image I can see noises surrounding that unlit light bulb on the right. Those noises almost look like the dust on my computer screen.



Portals only work for the world light, so forget that part.

Is your light behind glass? (or translucent/SSS shaders?) Don’t try to illuminate scenes with light that shines through a shader, you’ll just get too much noise. Your primary light should be direct light.

…and in general this is not a scene Cycles is very competent with.
Small light source + large room = slow convergence, especially if the light source is also “hidden” behind another surface.

Good to know. And my light is inside the middle of light bulb. I’m try that again.

OK, do I have other options for this kind of scenes?

Hi, add a point light close under the bulb and try a big mesh emitter on top outside the camera view with very low value.
Can you upload the file maybe?
We can play with it.

Cheers, mib

A good option is to change the glass material from the light bulb to transparent for shadow rays. (add a mixshader, a transparent shader and a lightpath node; connect the ‘is shadow ray’ to the factor of the mix, your glass setup to the first shader socket, and the transparent shader to the second socket)

This way, whenever a point is being shaded and it looks for a light, even if the glass is in the path, it will look transparent to the shadow ray, and the ray will hit the light. Otherwise, the ray stops at the glass, and the probabability of cycles throw a ray that hits the light through the refraction gets so low that is almost the same as if the light is not there.

take a look at this file[ATTACH]441979[/ATTACH]

take a look at this file[ATTACH]441979[/ATTACH]

Take a look at this file. It should clean in 1/100 of the time

Oh come on!
sorry, it was server mess…:o

Hey, that is an interesting plan.

So here is my blend files and their render results:

Originally I used the “Clamp Indirect” method. I set the value to 3. It killed all the noises instantly.

I came to the conclusion the sampling amount isn’t the problem here. 5120 samples is just the same as 512 samples.

Then I tried your method. I lowered the point light out of the bulb, and added an emission plane. It magically killed the noises too, the only problem is that the light bulb is now looking quite funny, if you look at the image.

Thanx for the help, I’ve been learning ^

Hey, Thanx for the lovely blend file ^

So I see you have the light inside the bulb with glass material and the image has no noise at all. The point light and that emission mesh is placed together inside the bulb. What’s the theory behind it? Why do you use the bevel and subsurf modifier on the cube, instead of just adding a sphere?

I changed the bulb material to glass+transparent mix. But clamping the indirect light was exactly what I did later on. It killed all the noises. However I heard I should use it with caution too since it may hurt light and brightness?

Good theories, but the noise amount goes crazy after this setup :()

Does my reply work?

How about this?

Your reply does work, but there isn’t much more to add :slight_smile:

If the indirect clamp is working, and you can’t see a problem with it, then no need to try anything else!

did some changes on your file…