(still) not able to render with GPU


I still dont get the option of using the GPU in the preferences.
My Graphic Card is a Geforce GTX 765M with CUDA compute ability of 3.0
Any help would be welcome as I dont have any clue how to go further now :-/

History of what I tried already:

What OS?
Which version of Blender?

Don’t expect too much from a dated notebook GPU. Depending on your CPU model, it might very well be on par or even slower than rendering on the CPU.

thanks for your answer,
I am running blender 2.77a on windows 7 (64 bits).
CPU : i7 4700 MQ (@2,4 GHz) // GPU: GTX 765M (2 GB : not sure how to read it) // Ram:16 GB

Hi, this card should work out of the box on Windows 7, what you can check:
Does Blender really use the Nvidia card? Look for Nvidia Optimus again.
Nvidia driver and “Windows update driver” are different, make sure you use the Nvidia one.
Every Windows update can overwrite the Nvidia driver again, you can disable it but Mirosoft has it very good hidden. :ba:

Cheers, mib

Hi mib,
I didnt know where to look for how to find if Blender uses the Nvidia card (where should I look?)
But I found this:

Does it say something interesting?

I guess this is wrong, as it tells your machine to use the integrated device (= graphics integrated into your CPU) for Blender.


What other option can you choose here?

The problem there is that the little arrow on the side is grey, I cant choose anything :-/

another info, when I right click on the Blender.exe, and stand on “execute with GPU”, no choice comes out, like its empty:

What are the options under “Globale Einstellungen” in your first screenshot?
Are you sure the driver is installed correctly? This indeed looks like some nVidia Optimus setup…

This “global Setting” stuff, I cant look into it to see what else is there, its all greyed out, inactive, kind of blocked.

Otherwise, for info, I tried today to install the new up to date Nvidia drivers (the version 368.81) but it was making my PC freeze all the time, impossible to do anything. So I made a system recovery and got back to the Nvidia version 353.30. Anyway, this new version of drivers were not helping with that problem, it was all the same.

You have to uninstall the old driver complete to get a clean system.
There is even software for it, first hit > http://www.chip.de/downloads/Display-Driver-Uninstaller-DDU_65992840.html

Cheers, mib

That happened to me once and it wasn’t the driver nor Windows 7. Honestly I should remember more since it ran me nut for an entire afternoon. Try going to File - Load Factory Settings and see if that helps.

  • To de-install the graphic drivers and re-install it sounds like an idea. I have to think twice though before because as far as I remember, the drivers on this laptop were a drag to install.
  • To Load the Blender Factory settings will not help I think in my case, I am having that same GPU problem since the beginning.
  • I have one question though, will I be able to render bigger scenes using the GPU instead of the CPU?
    My main concern was about rendering medium/large scenes including grass and trees.
    (I am using: blender 2.77a on windows 7 (64 bits).
    CPU : i7 4700 MQ (@2,4 GHz) // GPU: GTX 765M (2 GB : not sure how to read it) // Ram:16 GB)

No. The Achilles’ heel of GPU rendering has always been the available memory: When rendering on the CPU, you have the full system RAM at your disposal for your scenes, but when rendering on the GPU, any scene has to fit into the usually sparse VRAM.

So, in your case we’re talking about 16 GB RAM vs. only 2 GB VRAM, which is more or less the bare minimum these days. I’d say: Forget about GPU rendering.

Ok, for now, I will just let that project to the side.

about the 2GB Vram, I was not sure if it is correct, it has a CUDA compute ability of 3.0