STL Export Missing Sizing Information?

I should have probably posted this a while ago, but I wanted to make sure it was legit and not operator-error. :slight_smile:

I use Blender to create STL files for CNC routing and 3D printing. In previous versions this seemed to work okay, but in the latest version (2.63a) the size of the models doesn’t seem to get exported.

For instance: I’m working on a giant, 18" diameter pumpkin carved out of foam on the router. I used the Transform Panel to resize the piece to the appropriate dimensions. When I export the STL and bring it into CamBam or Skeinforge, it becomes microscopic. Resizing is quite a pain when I have to slice my models in Blender before exporting them (one piece is 18" across, the next one is something like 17.842", and on and on.)

This seems to be directly related to Blender as no one has reported problems with the other, lesser software in use (Sketchup, Solid Works, etc). :wink:

It could be that there’s a hidden setting somewhere to export sizing information, but damned if I can find it.

Any advice or help would be appreciated…

(I’m also having a problem with BMesh created faces not exporting correctly in STL files, but I’ll post about that later so I can attach a file…)

I always though 1 blender unit = 1mm when exported as .stl. Try exporting the default cube and see what size you get.

Oops, I should have mentioned that I’m using Imperial Units.

1 BU = 1"

But I’ll try with a default cube and see what happens…

…Okay, after resizing the test cube to 1’ square, I exported the STL, imported it into FreeMill, and its size was .3048".

Something is very screwy here…

If I had to guess (and assuming that I’m not doing anything wrong), it seems that resizing in imperial units screws up some calculations.

I’ve tried applying the size and rotation and it still gives me the same result…

Just did a test
Cube exported from zbrush as 10 x 10 x 10 mm, imported into blender as a 10 x 10 x 10 blender unit cube
Default cube 2 x 2 x 2 blender units, imported into zbrush as 2 x 2 x 2 mm

Changed blender to imperial. Cube set to 10" x 10" x 10" (ctrl+A to clear scale), imported into zbrush as a cube of 3.048 x 3.048 x 3.048mm.
In blender 10" is 3.048 when changed back to blender units

Therefore .stl exporter uses 1 BU = 1mm