STL mesh creating "shadows" when rendering

hey guys,
im product rendering, i export from solid edge as an stl.
the mesh from this one particular part creates a mesh around screw holes that appear when i render the object
ive tried a few different things to solve this.
ive outputed the mesh as finely as i can from solid edge,

in blender ive sub divided the mesh, changed it to a QUAD mesh, i add an edge split modifier, i smooth, and it still gives me the same result. does anyone have any suggestions that i cant try to give me a smoother mesh?



the problem here is the quads, you heard they are good, but not realized why.
Well they’re good for texturing, but also good to follow shape, i guess you used some kind of autodesk product to get that model.
And not sure why but they tend to create terrible mesh layout, and small errors in hight, and small errors in corners result in strange effects. Often i also see poor connections in faces not realy connecting in such models (although they should) => verticles remove doubles as under edit mode often helps there.

a few options that might solve it.

  • select all involved mesh areas on this flat surface, pres S for scale, Z for axis and press 0 enter, all must now be at exact same Z position.

  • redraw the bad parts using blender, then you might put in a proper quad

  • if its not for 3d printing, and it doesnt need to be watertight (cad models somehow often fail this to be often), then put a simple flat face over it, leave original mesh below.

  • redraw the entire thing in blender, something i often did since the trouble as caused by autodesk programs often costed me to much time to solve, and it was often faster to redraw it (if you dont require an exact match of the given model).

Try this app http://igl.ethz.ch/projects/instant-meshes/ It makes nice quads with little effort (once you understand the settings). You can even draw on the object to redirect the topology, but not necessary for an object like you show.

Your problem has to do with vertex shading and how it shades across a tri. In short skinny tri’s tend to be bad news for vert shading. Which, you have a lot around those cricles. Simple ways to fix this are making the tris larger or in your case converting them to quad edge loops.

A lot of times if the offending tri is on a planar surface, simply separating that plane from the model with an edge split solves the problem but that isn’t always the case.