stop Camera scrolling?

https://youtu.be/NVYEdJQ97Tc

so pretty much the camera scrolls when i use the middle mouse button and the camera is not selected I dont know how to turn this off or how it got there

Press N , at the “View” tab, see if you have “Lock Camera to View” .
If it is enabled, disable it.

worked thannks