Stop grass going through objects

I’ve been using blender for a few weeks.

Basically I don’t want the grass going through the chair or the crate. Is there a way to hide those blades that do.

This is a still image, not animation

Please help

Cheers

  1. you can create a vertex group for the plane (which should be subdivided a few times) with weights of 1(Red) everywhere, and 0.0 right below the chair, and you can assign that vertex group in the particle system

  2. if it;s hair you can comb it, or shrink brush it in particle edit mode

  3. you can keep changing the random seed value in the particle system until you find one that isn’t poking through

4.) you can apply the particle system modifier and then manually delete the problem blades

1 Like

hey thanks for being so rapid

I’m in particle edit mode but now cant see the blades i want to shrink - i did create these with the hair particle method

I remember using the seed randomising feature when creating the plane but i cant find it now

I also thing the grass is some sort of child to the trees (right hand side you can see) because i can modify the trees particles but not the grass

toward the top, under ‘emission’ ecpand the manu, and you’ll see seed

it appears to be greyed out, when i try to change it, it doesnt let me

I think if they go into.particle edit and brush then some of the of settings become locked and you have to ‘free edit’ to roll back things. I would try using the vertex group method, do u know how to weight paint or assign vertices to a vertex group manually?

hope you can see

How about applying the modifier (4)

I’ve applied it but not sure how to delete the blades. When i tab into edit mode i see:

:frowning: no i dont know how to do option no.1 i’m such a noob

Can i send a wetransfer of the project?

I’m on my phone for a bit, u can send a file, but in this case there’s nothing “wrong”

google for a couple tutorials on vertex groups + hair in blender.

ok ill have a look on those subjects meanwhile - thank you

this reminds me of when i first started out on photoshop lol, not knowing a damn thing

cheers

I found this tutorial

Although an older version, helped me figure it out

I selected the vertices, face & edges below the chair and then made assigned it as a group, then went to control the length and density in vertex groups (particles properties)

But this didn’t work - what i did was invert the original selection so all the vertices around the chair was selected instead and did the same process and it worked.

its not perfect but you cant tell in camera view

thanks for putting me in the right direction

looking good, particle systems you just have to play around with them and experiment, make sure if it’s looking good to save the blend and then’save as’ with a number appended to the end of the filename, so you have a few versions in case you accidentally destroy your file, which will happen many times. :-9

Yeah Ive watched a few things about saving copies which I think is there for situations like this

I’ve already destroyed things :sweat_smile:

Thanks again