Straight Lines to Curves

Here is a model im currently working on :
http://img115.imageshack.us/my.php?image=92379001xr4.jpg

As you see, the selection is all straight edges. That selection would be an indented window, however, is there a special tehnique to transmute those V shaped lines in smooth round curves?

these seems to be edges and are always straight lines in blender

you want see most of it on render unless you got a low res model
but you could use the subsurf tand smooth o make it look more rounded

Salutaitons

well, yeah, but is there no trick except subsurf? If I detach the edge, subsurf it and attach it back it looks horrible due to the increased vertex count. Should be an edge to curve stuff with the apropriate geometry processing in place …

With those vertices selected, you could try enabling Proportional Edit Falloff (O and ALT+O in Edit Mode) and drag the selection down. I believe you would still want the Subsurf Modifier though(Without detaching the selection).
http://wiki.blender.org/index.php/Manual/Proportional_Edit

To Shere might help too. SHIFT+CTRL+S and drag the mouse until it looks good, then LMB or Enter.

Sculpt is another option. The inflate and smooth options.
http://wiki.blender.org/index.php/Manual/SculptMode

Hope this helps.

Checked out those tools, they are really great, but not what I need sadly :frowning:
There’s no clean way to make those edges round on the same plane as the rest of the mesh I guess. Blender limitation.

Try this: take your selection, copy it (shift-D), and separate the copy to a new mesh with P. Now, in solid view mode select the copy mesh and in edit mode turn on retopo to keep it stuck to the original mesh. Now you can do W-smooth a few times to smooth out the corners of the mesh. When you are satisfied rejoin the two meshes together and connect them up.

I took my selection, copied it, disjointed it from the main mesh with P, retopo’ed it. I smoothed it a few times but it looks very bad, noy rounded at all, the only rounded thing is where I dont want it to be, mainly at the front and not the corners. What’s the keyboard shorcut to join two meshes though?

Before smoothing the mesh, try selecting the outside border edges, extrude them and scale them out a bit (with retopo on). Then smooth as necessary.

The shortcut for joining meshes is ctrl-J.

Nah, I still get weird results, :frowning: it amazes me I can’t take an edge and just bevel the corners …

Research… Topology

You’r trying to force a round hole into a square peg. :wink:

I tried with topo as he said … and yeah, but I was thinking that the software could create aditional points to compensate.

No, pappy meant topology, not retopology (retopo). :slight_smile:

Topology basically means the location and arrangement of vertices in a mesh, the flow of loops, etc. Pappy’s point is that your mesh is working against what you want to do with it.

If you can wait until tomorrow I would like to explain some things about your situation that could help you improve your results, but I’m out of time now. In the meantime, try again with my suggestions, this time using subsurf on your models if it’s not already enabled.

You know, for topoly and how to control it, you might want to check out this thead: http://blenderartists.org/forum/showthread.php?t=93651

With this, you’ll be able to gain control over the topology in your mesh and, thus, solve the problem remarked by pappy.

I think there are two issues in your model, topology and use of subsurf.

I may be wrong, but it looks like you got your mesh by taking a cube, deforming it and maybe adding a few loops here and there, and then taking a high level subsurf and applying it. Aside from trying to use subsurf to try to make a rectangular object look round (topology again :)), this creates an unnecessarily high poly object to work with, and more importantly removes subsurf from acting on the mesh and helping smooth things out for you.

I would suggest redoing the fuselage model you have, and try to model with subsurf enabled as a modifier. Start with a circle or cylinder initially, extrude and scale to regain your original shape. Try to use as few vertices as possible while keeping the subsurfed model smooth.

When you get to modeling the windshield, read the link techwielder posted and reread this thread for hints how to create a nice opening for it. In your old model the corner vertices I circled below are bad, and the triangles you created are also bad. Basically you want a single edge loop defining the opening for the windshield, following the path I marked in blue below.


Good luck!