Strange 3D view, object edit mode behavior.

Like in topic, just see blend from link below, enter edit mode and rotate the view. This is not the scale or view clipping issue I try it both, always get the same strange result. Any ideas? It drives me to madness, earlier i haven’t such a behavior.

http://speedy.sh/72MgP/RobotTracking.blend

PC specs:

Athlon x2 2,65, GeForce GT 430 2048, 4096 Ram, and the newest graphic card drivers from nvidia.

Hope You can help me.
Best Regards.

OK it was because “rotate around selection” was check in preferences. But anyway? Why it behave like that? Also when i try get in local mode (this is only with “point cloud” object generate from movie clip editor) it blows the view away. Any ideas how to fix it?

You have some stray points that make your object ginormous.
Select that points you can see, Ctrl+I to invert selection and X / delete vertex

Attachments