Strange behaviour of fluid simulator: Obstacles not detected


(ROUBAL) #1

Hi ! I’m playing with the fluid simulator in Blender 2.40 alpha1:

I have encountered two issues:

1 - I wanted to simulate water poured in a glass.

I have used a cylinder for the glass, with the upper side opended by removing the vertex at the center.

Normals are recalculated outside (tried too with normals inside).

I have put it in the domain object and set as an obstacle.

The water is stopped by the upper side, even if there is no upper side!

The bound box seems to be used for the obstacle instead of the real shape.

2 - I have made a trial with 2 planes (and with other objects too) with a hole, used as obstacle, to see the travel of the liquid…

The two planes are one obove the other, and set as obstacles.

The fluid ignores the first obstacle, and pass through it like there was no obstacle.

The second obstacle stops the liquid.

I have tried with 3 objects: this time, only the first and the third objects are detected as obstacles… the fluid passes through the second one!

Philippe.


(delt0r) #2

anychance of a blend file?


(ROUBAL) #3

As it didn’t worked, I haven’t kept the file. I can’t remake one right now, because I have not blender on this HardDisk, but you can easily make a blend.

You need a cube stretched in height for the domain, a cube or a sphere set as inflow object, and 3 planes at 30 degrees inclination, set as obstacles.

Alternate their position to get a sort of waterfall.

Nothing complicated.

Philippe.


(Jason van Gumster) #4

Try using a closed 3D object, rather than just a plane. I’d had problems with fluids breaking through my models before and the issue was alleviated by having a closed surface that wasn’t too thin. If I needed a thinner surface (or a plane), I set that object to be visible, but had the actual obstacle object on a different layer.


(ROUBAL) #5

Well, I tried too.

My first trial was with a thick object (an extruded subdivided plane in which I had removed a face before extrusion to make a hole in it) it was like a flattened cube with a hole… the problem was the same…

Do not forget the second problem: the bounding box seems to be used instead of object shape for the obstacles…

Philippe.


(ROUBAL) #6

Hummm…

I have done a new trial on my other PC… you seem to be right, now it works… probably something to do with the Normals…

Do you know which unit is used for the start and end time in the fluid simulator?

Real time in seconds instead of frame? As softbody use frames, it seems curious to find here a real time… but maybe it is the choice of the programmer if they have not been done by the same…

Philippe.


(n_t) #7

ROUBAL - yes, the fluid panels are in physical units where it makes sense, so time is in seconds, gravity in m/s^2 etc. at some point you have to calculate the parameters from real world values - unless you know how to set viscosity values in [m^2/blender-frames] for example :slight_smile:

However, it’s safer to rely on low-res test runs than on the absolute values… (the softbody things were done by other people btw.)


(ROUBAL) #8

Thanks for these informations.

For the obstacles, I think that it is better to used subdivided objects, to have a sufficient number of faces(and normals), like for the collisions in softbody…

Philippe.