Strange black dots

When I render there come small black dots but there is no dots at the texture. Why is it like this and how do I fix it? Here is an exaple:

What build? Is it YAFRay?

That is strange, I must say.

Are there particles supposed to be? I had similar problems when using hair strands without usnig strand shaders.

i had the same problem try turning photons of and cache on

I use Blender 2.37A, not YAFRAY, not particles. I ain’t sure but you can’t use photons and cache in Blender internal render.

Do these black dot show up in all the renderings or only this one?

Only on this project.

Does this project have different render settings?
Maybe there is some extra hidden geometry (“fighting faces/edges”)

It have worked well before and I don’t think that I have any hidden faces.

In Edit mode, W-Remove Doubles.


There were no doubles to remove.

Thats AO!

I’ve had that happen before too. When AO it at a very low sampling, like 1 or 2, there is strong noise. and with OSA enables, it becomes anti-aliased!

Just turn up the AO samples.

Thank you very much, Hafuni. It works now, Horray.