Strange bug/problem with Blender on Windows Vista


I have found a strange bug/problem with Blender while running on Windows Vista. I am pretty sure that this may affect the versions of Vista in which Aero can be run, but it could very well include all versions. For a little background, my computer has Windows Vista Ultimate 64-bit with all the newest updates installed. I am currently using Blender 2.49b, and I do not have Python installed. I am using a laptop with a Core 2 Duo T9550 processor, a 250 GB 7200 RPM hard drive, 4 GB of DDR2, and a GeForce 9300M GS.

The bug/problem:

If “Desktop Composition” is not enabled in “Visual Effects,” the performance of Blender is negatively affected. The interface lags, and any movement in the 3D space is sluggish. However, when Desktop Composition IS enabled, the performance of the interface/3D space is great.

For anyone running Blender on Vista, could you confirm/deny this issue? :confused:


I didn’t have this problem, but on the internet I found some people saying that it would be a good idea to disable it for graphics applications, so I am trying that now.

Thanks for bringing it up.


Yes. I have had this problem. It’s in the way Vista renders the desktop when you disable visual effects. Like so many aspects of so many versions of windose, they didn’t really spend time on the design(eye candy) for you to run it turned off, so it’s buggy.

In Vista, DirectX is used for all desktop rendering, it’s hardware accelerated. By turning off desktop composition, you are forcing Vista to use DirectX more like it used GDI in the past. No acceleration.

I disabled visual effects thinking that it would free up memory and perhaps speed up over-all performance a little. The result was very negative, not just in Blender but everywhere. Even explorer stutters and lags when I use Java. Vista is strange. Turn on visual effects, let it eat up your memory, and everything will run smoother. :spin:

I run Blender on Vista 32 bit. Initially, I had problems running with the Aero color scheme. The Blender screen would come up black, or parts of the Blender startup image would hang around, at unpredictable times. When I changed to Windows Classic, these problems went away.

Perhaps reverting to the classic theme might help. Also, keep in mind that Blender doesn’t have a full installer for 64 bit Vista, which implies that there may be some glitches to iron out.