Strange cube edges

What’s causing the cube edges to become dark grey? I tried flipping the normals, but get the same result.

Steps taken:

  1. Create cube
  2. Subdivide several times
  3. Set smooth
  4. Render

Attachments


If it isnt normals, then sometimes it can be a result of a duplicated object inside the other…if that makes sense…

Only one cube, no duplicates.
d2

Did you possibly set the edges to full crease? I ask because a subdivided cube usually is round on the edges, and your pic looks really hard. I usually use extra loop cuts to bring out the edges I need instead of using the edge creasing.

Have you tried starting over? We’re talking just trying to see if it happens again without touching any edge settings…
If not, I’m lost as well.

I tried starting over and did nothing to the cube except subdivide then set smooth and always get the same dark edge result.

Here is what it looks like when I do one more step, turn on No V.Normal Flip. Now it looks like it has toon edges, but Edge isn’t turned on.

d2

Attachments


No, don’t use Set smooth on an object with only sharp edges, at least not without having Autosmooth enabled. Press the button and leave the standard settings, that should resolve the problem.

Or, don’t use set smooth on a cube.

Here is a cube which I Subdivided several times then added Subsurf and Set Smooth. I used Set Smooth so I wouldn’t have to set Subsurf too high. Looks like this is the way to do it. Of course, Bevel is also another option.

d2

Attachments


Sorry to bring that back but did you actually try what I suggested? Or what else do you want to achieve? A cube with beveled / soft edges?

Otherwise there is really no point in using Set Smooth on a cube.