Strange Cycles Behaviour


First of all I am very new to Blender. This is a render of my first attempt at a car.

When I set my Viewport shading to Rendered I see the results I expect. When I render the image from the Render panel I get a worse result with strange shapes and shadows. Like I said, I don’t have a lot of experience with Blender. This doesn’t happen in any of my other files, just this one.

Does anyone know why this is happening?


couple of possibilities…I think it might be the fact that when rendering in viewport it is rendering your point of view, and this changes when hitting f12 to the cameras perspective. I’m not sure whats going on with the door it looks repositioned?, normally dark lines on the render suggests topoligy or nrmal issues but I dont think thats the case here. If you dont know how to solve normal issues, In edit mode with all vertices highlighted press ctrl n, which will uniform all normals, some of the reflections may be the objects your using as lights, either uncheck the camera in outliner menu beside light objects name, or reposition and see if it helps. I dont use cycles, so you will more than likely get better answer than this

Wow you did a really good job, I just started so it will take me a while till i can do something like that.

Check to make sure that you don’t have the AO pass turned on in the render layers.

You have subdivision surface modifiers that have a lower “Render” than “View” setting, resulting in a coarser mesh being used for F12 renders.

No luck.

well dunne, I fixed the normals and tried unchecking light sources.
Spencer14, thanks!
m9105826, AO pass was off.
Zalamander, my View value was lower than Render. I made them the same value just to experiment but that didn’t work either.

Thanks everyone for your advice.

it gets easier spencer with practice. keep at it and who knows, you may be 20 times better!!

Thought - could it be that you have geometry duplicated in another layer that doesn’t show while you are working on your preview render, but is present in your final render?

It looks like subsurf on the car body just doesn’t work in the F12 render.


I made a copy of the file and applied all of the subsurfs. Now the F12 render matches the viewport render. I guess we just chalk it up as a “weird subsurf problem”? :confused: