Strange denoise with optix

Hello Community,

I started a newproject and I notice strange behaviour of denoise with Optix. I have a RTX3090 and on other files I do not have this problem ( exterior scene ). For this specific scene Open denoise works way better than Optix.
As soon as i remove the ceiling the denoise works nicely with optix ( I have a physical sun outside )…

thank you for the advices.


Open denoise is usually better for final renders. It has filtering options and keeps more texture details. Optix is great for viewport previews because it’s faster, but it’s often not as good for a final result. Exterior scenes are always easier to render because the light source (the sky) is much easier for light rays to find than a small window.

Something you can do to improve this render is to put a light portal in the window. Light portals allows Cycles to know where windows are and to send light rays in their directions, so they can sample the sky.

How to do it:
-Create an area light.
-Place it exactly in the window, with the exact shape and size, pointing towards the inside of the room.
-Go in the light’s settings and check “portal”.
-The light is now invisible and is used only to guide the light rays through the window.

Your render should now get less noise for the same amount of samples.

1 Like

You try 3.2 beta or 3.3 alpha to see if the problem persists:

If the problem persists, you can report the problem to the bug tracker (Open Blender, Help menu, Report a bug). But for this it is necessary that you share with developers the .blend file where it is possible to reproduce the problem.

thanks a lot, I remember doing that with vray but forgot to do it with cycles. as soon as I removed the ceiling I understood that it must be a lack of light samples inside the room.

1 Like