strange distortion when transforming objects

It doesn’t happen in a new file, and it hasn’t happened before. I’m just wondering if I made some setting change that’s doing it.

The weird thing is, scaling or transforming LOOKS normal, with strange flickering, but once it’s committed and I change the viewing angle, suddenly vertexes are all over the place. I’ve been using Blender for a week now and this is the first it comes up. I tried restarting Blender - same problem. I tried moving the objects away from the origin, same problem.

Is this a bug? Or PEBKAC?



When you create an object, it defaults to “edit mode”. this allows you to select vertices, edges etc. Hit TAB to switch to object mode and then move your mesh.

moving the new cube in object mode works fine. however, i want to scale the cube, and every time i do it, it distorts it in some crazy way, conformed to axes or not. even if i hit ESC or RMB to cancel the operation, it ends up weirdly distorted, and always in a different way.

your 3D view is in Perspective view mode. do View->Orthographic.

What version of blender are you using? Does this only happen in this file or does it happen in all?

If that file, please post it, so we can see whats wrong.

using version 2.43

It happens in ortho and perspective view, by the way. I noticed that it happens more often when the cube i’m trying to scale intersects with the other objects, either when i’ve ended the scaling, or translation. strange things also occur when trying to scale along axes.

I can’t attach the file directly
here it is on my own website:

Does it have to do with the subsurfaced objects?

Also, I’d like to point out that I should be able to scale objects in either view - only being able to in one means the program isn’t working right! It only happens in this file, so far.

it happens more often when the cube i’m trying to scale intersects with the other objects,

Do you have Retopo on in the editing (F9) buttons? That’s the only function I can think of that would make different meshes interact this way in Edit mode. Turn it off.

I don’t see any distortion.


CD38, thanks a million! retopo was indeed on…