Strange domain-problem

Hello everyone!

Just a newbie here trying to learn Blender.

Yesterday I tried to make a very basic fluidsimulation: Just a box for domain and a sphere for the (initial) fluid.

When I turn my cube into a domain, it transforms into a ugly sphere with lots of bumps. It “works” until frame 51 like it should when I run the simulation with ALT+A, but seems to have become the fluid itself without no effect on the fluidsphere. Frame 52 just suddenly shows my domaincube like it should (a cube, not a bumpy sphere).

See the pictures and the attached .blendfile.

I have referred many different fluid-tutorials, but none of them seems to act like this.

What am I doing wrong?

Oh, I’m using Blender v2.57.1 r36524M


fluid.blend (361 KB)

It is correct that its the domain object that you see as the fluid in the simulation, and takes on the form of the fluid object. Just on the images I don’t see anything incorrect
Your blend file appears to only include a domain object, it also needs a fluid object to work.

Thanks Richard for responding.

I thought the domain-object should stay in the shape of a cube after watching tutorials, but that doesn’t really matter.

I have now added a simple sphere as the fluid-object inside the domaincube. When the simulation is run, that sphere stays there as an “ordinary” object (see attachment). Shouldn’t it act like … well… fluid…?

Sorry if this is a dumb question, but I don’t quite get grips on this.


fluid2.blend (396 KB)

In a word: no. Think of that fluid sphere as defining the initial shape of your incoming fluid. In fact, once you add the sphere to the scene and set its parameters, you’d be best moving that sphere to a disabled layer.

Hm… beginning to make sense now.

But how do I prevent the domain from turning back to a cube just after 2 sec into the animation?

How long did you bake your simulation for? If you only baked for 2 seconds, you only have 2 seconds of simulation. After that, you get the original domain shape (the cube).


I think I got it now. @Fweeb: you were right; I had to wait longer than 2 sec… :o

Thank you all for good help! Hopefully I too can give something back to you when I undertand more of what Blender can do.