Strange face protrusion when editing vertices

Hi

I’m very new to Blender and I’m just finding out about Edit Mode (so, yeah, really new to it!).

I tabbed into Edit Mode and moved 2 of the vertices belonging to the default cube that is present when Blender starts up. The problem I have is that one of the faces seems ok but the opposite face looks like there’s an extra edge that’s appeared. I’ve attached images to this post to show what I mean.

The first image seems ok to me with the right-hand dark grey face angled inwards, however the 2nd image looks like something extra has appeared making the left-hand face angle outwards from the cube rather than inwards. In wireframe mode it looks ok but not in solid or shaded mode. I’ve tried to use Ctrl+N to get Blender to recalculate the normals (got this from the back of my Blender for Dummies book), but it makes no difference.

Any ideas?

Thanks

Attachments



This happens because there aren’t really any quads; they’re just two triangles stuck together to make life easier on you (and on Subsurf). A quad doesn’t always have to be flat; a triangle can’t be anything else, so the triangle is the base of all 3D.

What to do here depends on what you want to do. If you plan on adding Subsurf or Multires at some point, don’t bother with this. The algorithm smoothes it all to the same nice curvy plane.

If you plan on keeping this lowpoly, you’ll have to triangulate manually if you want to control the edge. Ctrl+T for triangulate, Ctrl+Shift+F to flip the edge. Some other 3D applications are nice enough to remember this flipping and allow you to make a quad out of it again, but Blender won’t, unfortunately. It’s impossible to keep the same smoothing (which isn’t actually too add, because the smoothing you have going on now is theoretically impossible), but adding an EdgeSplit modifier, setting shading to Smooth and marking all the edges but the ones for triangulation as sharp should suffice.

Thanks for the comprehensive response. Some of what you say is a little over my head at the moment, but I’m sure it will begin to fall into place. I tried to triangulate the problematic face and that allowed me to fix the problem.